GHSA-94v7-wxj6-r2q5 multicast in source builds from vulnerable setuptools dependency
Not scored
Published
Check this codebase for GHSA-94v7-wxj6-r2q5 and fix it if it is affected.
What it is: GHSA-94v7-wxj6-r2q5 is a vulnerability in multicast, published on 28 May 2025. An attacker can exploit it over the internet without logging in, with no action from the victim.
Exploitation: There is no known exploitation of GHSA-94v7-wxj6-r2q5 in the wild and no public exploit code.
Affected packages and fixed versions:
- multicast (PyPI): affected all versions; fixed in 2.0.9a0
- multicast (PyPI): affected all versions; fixed in 2.0.9a0
Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.
Reference: https://insights.sbomify.com/GHSA-94v7-wxj6-r2q5/ (Markdown: https://insights.sbomify.com/GHSA-94v7-wxj6-r2q5/index.md)
Source builds using vulnerable setuptools dependencies may allow arbitrary code execution or modification via supply chain compromise.
- Exploited in the wild
- Not known
- Login needed
- Not needed
- Attackable
- Over the internet
- Victim action needed
- Not needed
- Fix
- Available
What is GHSA-94v7-wxj6-r2q5?
GHSA-94v7-wxj6-r2q5 is a vulnerability in multicast, published on 28 May 2025. An attacker can exploit it over the internet without logging in, with no action from the victim.
Official description
Impact
- Some source-builds may be impacted by a CWE-1395 (eg. vulnerable
setuptoolsdependency).- Multicast prior to v2.0.9a3 on systems with minimal dependancies installed may use
setuptools <78.1.1and thus rely on a compromised dependency. In some cases there is a chance that source-builds would fail due to an exploit of the closely related CVE-2025-47273, or become arbitrarily modified.
- Multicast prior to v2.0.9a3 on systems with minimal dependancies installed may use
Patches
- Pre-release version v2.0.9a0 and later resolve the issue by bumping requirements to
setuptools>=80.4- Pre-release version v2.0.9a3 and later are recommended for improved stability over v2.0.9a0
Workarounds
- Further hardening in v2.0.9a4+ of the build process in CI builds allowing source builds to be verified via GH attestations.
References
- GHSA-5rjg-fvgr-3xxf
- pypa/setuptools#4946
Fixes
- https://github.com/reactive-firewall/multicast/blob/c5c7c7de272421d944beca8452871bca6bfd151f/tests/requirements.txt#L32
- https://github.com/reactive-firewall/multicast/blob/c5c7c7de272421d944beca8452871bca6bfd151f/docs/requirements.txt#L27
- https://github.com/reactive-firewall/multicast/blob/c5c7c7de272421d944beca8452871bca6bfd151f/requirements.txt#L26
- https://github.com/reactive-firewall/multicast/blob/c5c7c7de272421d944beca8452871bca6bfd151f/pyproject.toml#L2
Which versions are affected by GHSA-94v7-wxj6-r2q5?
2 open source packages ship an affected version, including multicast.
| Package | Affected | Fixed in |
|---|---|---|
multicast PyPI | All versions | 2.0.9a0 |
multicast PyPI | All versions | 2.0.9a0 |
How do I fix GHSA-94v7-wxj6-r2q5?
Upgrade multicast to 2.0.9a0 or later.
Is GHSA-94v7-wxj6-r2q5 being exploited?
There is no known exploitation of GHSA-94v7-wxj6-r2q5 in the wild and no public exploit code.