{"answers":{"affected":"2 open source packages ship an affected version, including multicast.","exploited":"There is no known exploitation of GHSA-94v7-wxj6-r2q5 in the wild and no public exploit code.","fix":"Upgrade multicast to 2.0.9a0 or later.","what":"GHSA-94v7-wxj6-r2q5 is a vulnerability in multicast, published on 28 May 2025. An attacker can exploit it over the internet without logging in, with no action from the victim."},"fix_prompt":"Check this codebase for GHSA-94v7-wxj6-r2q5 and fix it if it is affected.\n\nWhat it is: GHSA-94v7-wxj6-r2q5 is a vulnerability in multicast, published on 28 May 2025. An attacker can exploit it over the internet without logging in, with no action from the victim.\nExploitation: There is no known exploitation of GHSA-94v7-wxj6-r2q5 in the wild and no public exploit code.\n\nAffected packages and fixed versions:\n- multicast (PyPI): affected all versions; fixed in 2.0.9a0\n- multicast (PyPI): affected all versions; fixed in 2.0.9a0\n\nTask:\n1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.\n2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.\n3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.\n4. Run the tests and summarise what changed and why.\n5. If nothing in the project is affected, say so and change nothing.\n\nReference: https://insights.sbomify.com/GHSA-94v7-wxj6-r2q5/ (Markdown: https://insights.sbomify.com/GHSA-94v7-wxj6-r2q5/index.md)","id":"GHSA-94v7-wxj6-r2q5","markdown":"https://insights.sbomify.com/GHSA-94v7-wxj6-r2q5/index.md","name":"GHSA-94v7-wxj6-r2q5","record":{"aliases":[],"analysis":{"component_type":"library","fix_type":"upgrade","impacts":["code_execution","data_modify"],"network_reachable":"yes","non_default_config":false,"product_category":"Python multicast library","requires_auth":"none","summary":"Source builds using vulnerable setuptools dependencies may allow arbitrary code execution or modification via supply chain compromise.","user_interaction":"not_required","vuln_class":"supply_chain"},"analysis_generated_by":"qwen3.8-flash-next","assigner":null,"cpe":[],"cvss":{"score":null,"severity":null,"source":null,"vector":null,"version":null},"cwes":[],"description":"### Impact\n * Some source-builds may be impacted by a CWE-1395 (eg. vulnerable `setuptools` dependency).\n   * Multicast prior to v2.0.9a3 on systems with minimal dependancies installed may use `setuptools \u003c78.1.1` and thus rely on a compromised dependency. In some cases there is a chance that source-builds would fail due to an exploit of the closely related CVE-2025-47273, or become arbitrarily modified.\n\n### Patches\n * Pre-release version v2.0.9a0 and later resolve the issue by bumping requirements to `setuptools\u003e=80.4`\n   * Pre-release version v2.0.9a3 and later are recommended for improved stability over v2.0.9a0\n\n### Workarounds\n * Further hardening in v2.0.9a4+ of the build process in CI builds allowing source builds to be verified via GH attestations.\n\n### References\n* [GHSA-5rjg-fvgr-3xxf](https://github.com/pypa/setuptools/security/advisories/GHSA-5rjg-fvgr-3xxf)\n* pypa/setuptools#4946\n\n### Fixes\n* https://github.com/reactive-firewall/multicast/blob/c5c7c7de272421d944beca8452871bca6bfd151f/tests/requirements.txt#L32\n* https://github.com/reactive-firewall/multicast/blob/c5c7c7de272421d944beca8452871bca6bfd151f/docs/requirements.txt#L27\n* https://github.com/reactive-firewall/multicast/blob/c5c7c7de272421d944beca8452871bca6bfd151f/requirements.txt#L26\n* https://github.com/reactive-firewall/multicast/blob/c5c7c7de272421d944beca8452871bca6bfd151f/pyproject.toml#L2","ecosystems":["PyPI"],"exploits":{"exploitdb":null,"first_seen":null,"github_poc":null,"max_poc_stars":null,"metasploit":null,"nuclei":null,"refs":[],"tier":null},"has_fix":true,"headline":"multicast in source builds from vulnerable setuptools dependency","id":"GHSA-94v7-wxj6-r2q5","indexable":true,"kev":null,"kind":"advisory","links":{"ecosystem":"PyPI","product":null,"products":[],"type":"supply_chain","year":"2025"},"n_packages":2,"n_references":null,"packages":[{"ecosystem":"PyPI","fixed":["2.0.9a0"],"introduced":["0"],"last_affected":[],"package":"multicast","purl":null,"source":"GHSA-94v7-wxj6-r2q5"},{"ecosystem":"PyPI","fixed":["2.0.9a0"],"introduced":["0"],"last_affected":[],"package":"multicast","purl":"pkg:pypi/multicast","source":"GHSA-94v7-wxj6-r2q5"}],"products":null,"published":"2025-05-28","related":[],"sources":[{"class":"attribution","licence":"CC BY 4.0","name":"GitHub Advisory Database","prefix":"GHSA"}],"ssvc":{"automatable":null,"exploitation":null,"technical_impact":null},"state":null,"updated":null,"vendors":null},"summary":"Source builds using vulnerable setuptools dependencies may allow arbitrary code execution or modification via supply chain compromise.","url":"https://insights.sbomify.com/GHSA-94v7-wxj6-r2q5/"}