{"answers":{"affected":"2 open source packages ship an affected version, including imagecodecs.","exploited":"There is no known exploitation of GHSA-94vc-p8w7-5p49 in the wild and no public exploit code.","fix":"Upgrade imagecodecs to 2023.9.18 or later.","what":"GHSA-94vc-p8w7-5p49 is a memory corruption vulnerability in imagecodecs, published on 5 Oct 2023. An attacker can exploit it over the internet without logging in, and only if a user opens a file or follows a link."},"fix_prompt":"Check this codebase for GHSA-94vc-p8w7-5p49 and fix it if it is affected.\n\nWhat it is: GHSA-94vc-p8w7-5p49 is a memory corruption vulnerability in imagecodecs, published on 5 Oct 2023. An attacker can exploit it over the internet without logging in, and only if a user opens a file or follows a link.\nExploitation: There is no known exploitation of GHSA-94vc-p8w7-5p49 in the wild and no public exploit code.\n\nAffected packages and fixed versions:\n- imagecodecs (PyPI): affected all versions; fixed in 2023.9.18\n- imagecodecs (PyPI): affected all versions; fixed in 2023.9.18\n\nTask:\n1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.\n2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.\n3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.\n4. Run the tests and summarise what changed and why.\n5. If nothing in the project is affected, say so and change nothing.\n\nReference: https://insights.sbomify.com/GHSA-94vc-p8w7-5p49/ (Markdown: https://insights.sbomify.com/GHSA-94vc-p8w7-5p49/index.md)","id":"GHSA-94vc-p8w7-5p49","markdown":"https://insights.sbomify.com/GHSA-94vc-p8w7-5p49/index.md","name":"GHSA-94vc-p8w7-5p49","record":{"aliases":[],"analysis":{"component_type":"library","fix_type":"upgrade","impacts":["code_execution","denial_of_service"],"network_reachable":"yes","non_default_config":false,"product_category":"Python image library","requires_auth":"none","summary":"Attackers can execute arbitrary code or cause denial of service by tricking users into processing malicious WebP images with vulnerable imagecodecs versions.","user_interaction":"required","vuln_class":"memory_corruption"},"analysis_generated_by":"qwen3.8-flash-next","assigner":null,"cpe":[],"cvss":{"score":null,"severity":null,"source":null,"vector":null,"version":null},"cwes":[],"description":"imagecodecs versions before v2023.9.18 bundled libwebp binaries in wheels that are vulnerable to CVE-2023-5129 (previously CVE-2023-4863). imagecodecs v2023.9.18 upgrades the bundled libwebp binary to v1.3.2.","ecosystems":["PyPI"],"exploits":{"exploitdb":null,"first_seen":null,"github_poc":null,"max_poc_stars":null,"metasploit":null,"nuclei":null,"refs":[],"tier":null},"has_fix":true,"headline":"Bundled libwebp in imagecodecs vulnerable","id":"GHSA-94vc-p8w7-5p49","indexable":true,"kev":null,"kind":"advisory","links":{"ecosystem":"PyPI","product":null,"products":[],"type":"memory_corruption","year":"2023"},"n_packages":2,"n_references":null,"packages":[{"ecosystem":"PyPI","fixed":["2023.9.18"],"introduced":["0"],"last_affected":[],"package":"imagecodecs","purl":null,"source":"GHSA-94vc-p8w7-5p49"},{"ecosystem":"PyPI","fixed":["2023.9.18"],"introduced":["0"],"last_affected":[],"package":"imagecodecs","purl":"pkg:pypi/imagecodecs","source":"GHSA-94vc-p8w7-5p49"}],"products":null,"published":"2023-10-05","related":[],"sources":[{"class":"attribution","licence":"CC BY 4.0","name":"GitHub Advisory Database","prefix":"GHSA"}],"ssvc":{"automatable":null,"exploitation":null,"technical_impact":null},"state":null,"updated":null,"vendors":null},"summary":"Attackers can execute arbitrary code or cause denial of service by tricking users into processing malicious WebP images with vulnerable imagecodecs versions.","url":"https://insights.sbomify.com/GHSA-94vc-p8w7-5p49/"}