{"answers":{"affected":"3 open source packages ship an affected version, including fast-able.","exploited":"There is no known exploitation of GHSA-95hm-pr6q-298w in the wild and no public exploit code.","fix":"Upgrade fast-able to 1.13.7 or later.","what":"GHSA-95hm-pr6q-298w is a denial of service vulnerability in fast-able, published on 25 Apr 2025. An attacker can exploit it over the internet without logging in, with no action from the victim."},"fix_prompt":"Check this codebase for GHSA-95hm-pr6q-298w and fix it if it is affected.\n\nWhat it is: GHSA-95hm-pr6q-298w is a denial of service vulnerability in fast-able, published on 25 Apr 2025. An attacker can exploit it over the internet without logging in, with no action from the victim.\nExploitation: There is no known exploitation of GHSA-95hm-pr6q-298w in the wild and no public exploit code.\n\nAffected packages and fixed versions:\n- fast-able (crates.io): affected all versions; fixed in 1.13.7\n- fast-able (crates.io): affected all versions; fixed in 1.13.7\n- fast-able (crates.io): affected from 0.0.0-0; fixed in 1.13.7\n\nTask:\n1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.\n2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.\n3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.\n4. Run the tests and summarise what changed and why.\n5. If nothing in the project is affected, say so and change nothing.\n\nReference: https://insights.sbomify.com/GHSA-95hm-pr6q-298w/ (Markdown: https://insights.sbomify.com/GHSA-95hm-pr6q-298w/index.md)","id":"GHSA-95hm-pr6q-298w","markdown":"https://insights.sbomify.com/GHSA-95hm-pr6q-298w/index.md","name":"GHSA-95hm-pr6q-298w","record":{"aliases":["RUSTSEC-2025-0063"],"analysis":{"component_type":"library","fix_type":"upgrade","impacts":["denial_of_service"],"network_reachable":"yes","non_default_config":false,"product_category":"Rust vector library","requires_auth":"none","summary":"An attacker can cause a denial of service by triggering an unchecked index access in the SyncVec struct of the fast-able Rust library.","user_interaction":"not_required","vuln_class":"denial_of_service"},"analysis_generated_by":"qwen3.8-flash-next","assigner":null,"cpe":[],"cvss":{"score":null,"severity":null,"source":null,"vector":null,"version":null},"cwes":[],"description":"The public accessible struct SyncVec has a public safe method get_unchecked. It accept a parameter index and used in the get_unchecked without sufficient checks as mentioned [here](https://doc.rust-lang.org/std/primitive.slice.html#method.get_unchecked).","ecosystems":["crates.io"],"exploits":{"exploitdb":null,"first_seen":null,"github_poc":null,"max_poc_stars":null,"metasploit":null,"nuclei":null,"refs":[],"tier":null},"has_fix":true,"headline":"Possible unsound public API","id":"GHSA-95hm-pr6q-298w","indexable":true,"kev":null,"kind":"advisory","links":{"ecosystem":"crates.io","product":null,"products":[],"type":"denial_of_service","year":"2025"},"n_packages":3,"n_references":null,"packages":[{"ecosystem":"crates.io","fixed":["1.13.7"],"introduced":["0"],"last_affected":[],"package":"fast-able","purl":null,"source":"GHSA-95hm-pr6q-298w"},{"ecosystem":"crates.io","fixed":["1.13.7"],"introduced":["0"],"last_affected":[],"package":"fast-able","purl":"pkg:cargo/fast-able","source":"GHSA-95hm-pr6q-298w"},{"ecosystem":"crates.io","fixed":["1.13.7"],"introduced":["0.0.0-0"],"last_affected":[],"package":"fast-able","purl":"pkg:cargo/fast-able","source":"RUSTSEC-2025-0063"}],"products":null,"published":"2025-04-25","related":[],"sources":[{"class":"attribution","licence":"CC BY 4.0","name":"GitHub Advisory Database","prefix":"GHSA"},{"class":"open","licence":"CC0 1.0","name":"RustSec","prefix":"RUSTSEC"}],"ssvc":{"automatable":null,"exploitation":null,"technical_impact":null},"state":null,"updated":null,"vendors":null},"summary":"An attacker can cause a denial of service by triggering an unchecked index access in the SyncVec struct of the fast-able Rust library.","url":"https://insights.sbomify.com/GHSA-95hm-pr6q-298w/"}