{"answers":{"affected":"2 open source packages ship an affected version, including mongodb-query-parser.","exploited":"There is no known exploitation of GHSA-97mg-3cr6-3x4c in the wild and no public exploit code.","fix":"Upgrade mongodb-query-parser to 2.0.0 or later.","what":"GHSA-97mg-3cr6-3x4c is a code injection vulnerability in mongodb-query-parser, published on 4 Sep 2020. An attacker can exploit it over the internet without logging in, with no action from the victim."},"fix_prompt":"Check this codebase for GHSA-97mg-3cr6-3x4c and fix it if it is affected.\n\nWhat it is: GHSA-97mg-3cr6-3x4c is a code injection vulnerability in mongodb-query-parser, published on 4 Sep 2020. An attacker can exploit it over the internet without logging in, with no action from the victim.\nExploitation: There is no known exploitation of GHSA-97mg-3cr6-3x4c in the wild and no public exploit code.\n\nAffected packages and fixed versions:\n- mongodb-query-parser (npm): affected all versions; fixed in 2.0.0\n- mongodb-query-parser (npm): affected all versions; fixed in 2.0.0\n\nTask:\n1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.\n2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.\n3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.\n4. Run the tests and summarise what changed and why.\n5. If nothing in the project is affected, say so and change nothing.\n\nReference: https://insights.sbomify.com/GHSA-97mg-3cr6-3x4c/ (Markdown: https://insights.sbomify.com/GHSA-97mg-3cr6-3x4c/index.md)","id":"GHSA-97mg-3cr6-3x4c","markdown":"https://insights.sbomify.com/GHSA-97mg-3cr6-3x4c/index.md","name":"GHSA-97mg-3cr6-3x4c","record":{"aliases":[],"analysis":{"component_type":"library","fix_type":"upgrade","impacts":["code_execution"],"network_reachable":"yes","non_default_config":false,"product_category":"Node.js query parser","requires_auth":"none","summary":"Attackers can execute arbitrary code by sending unsanitized queries to applications using the vulnerable mongodb-query-parser library.","user_interaction":"not_required","vuln_class":"code_injection"},"analysis_generated_by":"qwen3.8-flash-next","assigner":null,"cpe":[],"cvss":{"score":null,"severity":null,"source":null,"vector":null,"version":null},"cwes":[],"description":"Versions of `mongodb-query-parser` prior to 2.0.0 are vulnerable to Remote Code Execution. The package fails to sanitize queries, allowing attackers to execute arbitrary code in the system.  Parsing the following payload executes `touch test-file`: \n\n```'(function () { return (clearImmediate.constructor(\"return process;\")()).mainModule.require(\"child_process\").execSync(\"touch test-file\").toString()})()'```\n\n## Recommendation\n\nUpgrade to version 2.0.0 or later.","ecosystems":["npm"],"exploits":{"exploitdb":null,"first_seen":null,"github_poc":null,"max_poc_stars":null,"metasploit":null,"nuclei":null,"refs":[],"tier":null},"has_fix":true,"headline":"Remote Code Execution in mongodb-query-parser","id":"GHSA-97mg-3cr6-3x4c","indexable":true,"kev":null,"kind":"advisory","links":{"ecosystem":"npm","product":null,"products":[],"type":"code_injection","year":"2020"},"n_packages":2,"n_references":null,"packages":[{"ecosystem":"npm","fixed":["2.0.0"],"introduced":["0"],"last_affected":[],"package":"mongodb-query-parser","purl":null,"source":"GHSA-97mg-3cr6-3x4c"},{"ecosystem":"npm","fixed":["2.0.0"],"introduced":["0"],"last_affected":[],"package":"mongodb-query-parser","purl":"pkg:npm/mongodb-query-parser","source":"GHSA-97mg-3cr6-3x4c"}],"products":null,"published":"2020-09-04","related":[],"sources":[{"class":"attribution","licence":"CC BY 4.0","name":"GitHub Advisory Database","prefix":"GHSA"}],"ssvc":{"automatable":null,"exploitation":null,"technical_impact":null},"state":null,"updated":null,"vendors":null},"summary":"Attackers can execute arbitrary code by sending unsanitized queries to applications using the vulnerable mongodb-query-parser library.","url":"https://insights.sbomify.com/GHSA-97mg-3cr6-3x4c/"}