{"answers":{"affected":"2 open source packages ship an affected version, including auth0/symfony.","exploited":"There is no known exploitation of GHSA-98j6-67v3-mw34 in the wild and no public exploit code.","fix":"Upgrade auth0/symfony to 5.1.0 or later.","what":"GHSA-98j6-67v3-mw34 is an unsafe deserialization vulnerability in auth0/symfony, published on 6 Jun 2025. An attacker can exploit it over the internet without logging in, with no action from the victim."},"fix_prompt":"Check this codebase for GHSA-98j6-67v3-mw34 and fix it if it is affected.\n\nWhat it is: GHSA-98j6-67v3-mw34 is an unsafe deserialization vulnerability in auth0/symfony, published on 6 Jun 2025. An attacker can exploit it over the internet without logging in, with no action from the victim.\nExploitation: There is no known exploitation of GHSA-98j6-67v3-mw34 in the wild and no public exploit code.\n\nAffected packages and fixed versions:\n- auth0/symfony (Packagist): affected from 5.0.0-BETA0; fixed in 5.1.0\n- auth0/symfony (Packagist): affected from 5.0.0-BETA0; fixed in 5.1.0\n\nTask:\n1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.\n2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.\n3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.\n4. Run the tests and summarise what changed and why.\n5. If nothing in the project is affected, say so and change nothing.\n\nReference: https://insights.sbomify.com/GHSA-98j6-67v3-mw34/ (Markdown: https://insights.sbomify.com/GHSA-98j6-67v3-mw34/index.md)","id":"GHSA-98j6-67v3-mw34","markdown":"https://insights.sbomify.com/GHSA-98j6-67v3-mw34/index.md","name":"GHSA-98j6-67v3-mw34","record":{"aliases":[],"analysis":{"component_type":"library","fix_type":"upgrade","impacts":["code_execution"],"network_reachable":"yes","non_default_config":false,"product_category":"Auth0 Symfony SDK","requires_auth":"none","summary":"Attackers can execute arbitrary code by sending malicious serialized data in cookies to applications using the Auth0 Symfony SDK.","user_interaction":"not_required","vuln_class":"deserialization"},"analysis_generated_by":"qwen3.8-flash-next","assigner":null,"cpe":[],"cvss":{"score":null,"severity":null,"source":null,"vector":null,"version":null},"cwes":[],"description":"**Overview**\nThe Auth0 Symfony SDK contains a critical vulnerability due to insecure deserialization of cookie data. If exploited, since SDKs process cookie content without prior authentication, a threat actor could send a specially crafted cookie containing malicious serialized data.\n\n**Am I Affected?**\nYou are affected by this vulnerability if you meet the following preconditions:\n\n1. Applications using the Auth0 Symfony SDK, versions between 5.0.0 BETA-0 to 5.0.0. \n2. Auth0 Symfony SDK uses the Auth0-PHP SDK with version 8.0.0-BETA3 to 8.3.0.\n\n**Fix**\nUpgrade Auth0/symfony to the latest version (v5.4.0).\n\n**Acknowledgement**\nOkta would like to thank Andreas Forsblom for discovering this vulnerability.","ecosystems":["Packagist"],"exploits":{"exploitdb":null,"first_seen":null,"github_poc":null,"max_poc_stars":null,"metasploit":null,"nuclei":null,"refs":[],"tier":null},"has_fix":true,"headline":"Auth0 Symfony SDK Deserialization of Untrusted Data vulnerability","id":"GHSA-98j6-67v3-mw34","indexable":true,"kev":null,"kind":"advisory","links":{"ecosystem":"Packagist","product":null,"products":[],"type":"deserialization","year":"2025"},"n_packages":2,"n_references":null,"packages":[{"ecosystem":"Packagist","fixed":["5.1.0"],"introduced":["5.0.0-BETA0"],"last_affected":[],"package":"auth0/symfony","purl":null,"source":"GHSA-98j6-67v3-mw34"},{"ecosystem":"Packagist","fixed":["5.1.0"],"introduced":["5.0.0-BETA0"],"last_affected":[],"package":"auth0/symfony","purl":"pkg:composer/auth0/symfony","source":"GHSA-98j6-67v3-mw34"}],"products":null,"published":"2025-06-06","related":[],"sources":[{"class":"attribution","licence":"CC BY 4.0","name":"GitHub Advisory Database","prefix":"GHSA"}],"ssvc":{"automatable":null,"exploitation":null,"technical_impact":null},"state":null,"updated":null,"vendors":null},"summary":"Attackers can execute arbitrary code by sending malicious serialized data in cookies to applications using the Auth0 Symfony SDK.","url":"https://insights.sbomify.com/GHSA-98j6-67v3-mw34/"}