# GHSA-98j6-67v3-mw34: Auth0 Symfony SDK Deserialization of Untrusted Data vulnerability

> Attackers can execute arbitrary code by sending malicious serialized data in cookies to applications using the Auth0 Symfony SDK.

- **Severity:** Not scored
- **Exploited in the wild:** Not known
- **Login needed:** Not needed
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 6 Jun 2025

## What is GHSA-98j6-67v3-mw34?

GHSA-98j6-67v3-mw34 is an unsafe deserialization vulnerability in auth0/symfony, published on 6 Jun 2025. An attacker can exploit it over the internet without logging in, with no action from the victim.

### Official description

**Overview**
The Auth0 Symfony SDK contains a critical vulnerability due to insecure deserialization of cookie data. If exploited, since SDKs process cookie content without prior authentication, a threat actor could send a specially crafted cookie containing malicious serialized data.

**Am I Affected?**
You are affected by this vulnerability if you meet the following preconditions:

1. Applications using the Auth0 Symfony SDK, versions between 5.0.0 BETA-0 to 5.0.0. 
2. Auth0 Symfony SDK uses the Auth0-PHP SDK with version 8.0.0-BETA3 to 8.3.0.

**Fix**
Upgrade Auth0/symfony to the latest version (v5.4.0).

**Acknowledgement**
Okta would like to thank Andreas Forsblom for discovering this vulnerability.

## Which versions are affected by GHSA-98j6-67v3-mw34?

2 open source packages ship an affected version, including auth0/symfony.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `auth0/symfony` | Packagist | From 5.0.0-BETA0 | 5.1.0 |
| `auth0/symfony` | Packagist | From 5.0.0-BETA0 | 5.1.0 |

## How do I fix GHSA-98j6-67v3-mw34?

Upgrade auth0/symfony to 5.1.0 or later.

## Is GHSA-98j6-67v3-mw34 being exploited?

There is no known exploitation of GHSA-98j6-67v3-mw34 in the wild and no public exploit code.

## Fix prompt for AI coding agents

```text
Check this codebase for GHSA-98j6-67v3-mw34 and fix it if it is affected.

What it is: GHSA-98j6-67v3-mw34 is an unsafe deserialization vulnerability in auth0/symfony, published on 6 Jun 2025. An attacker can exploit it over the internet without logging in, with no action from the victim.
Exploitation: There is no known exploitation of GHSA-98j6-67v3-mw34 in the wild and no public exploit code.

Affected packages and fixed versions:
- auth0/symfony (Packagist): affected from 5.0.0-BETA0; fixed in 5.1.0
- auth0/symfony (Packagist): affected from 5.0.0-BETA0; fixed in 5.1.0

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/GHSA-98j6-67v3-mw34/ (Markdown: https://insights.sbomify.com/GHSA-98j6-67v3-mw34/index.md)
```

## Sources

- OSV: https://osv.dev/vulnerability/GHSA-98j6-67v3-mw34

---
From sbomify Insights: https://insights.sbomify.com/GHSA-98j6-67v3-mw34/
Summaries are generated and may contain mistakes; the official description above is the record.
