{"answers":{"affected":"2 open source packages ship an affected version, including ezsystems/ezplatform-admin-ui.","exploited":"There is no known exploitation of GHSA-99c7-c3mw-mxhv in the wild and no public exploit code.","fix":"Upgrade ezsystems/ezplatform-admin-ui to 2.3.39 or later.","what":"GHSA-99c7-c3mw-mxhv is a cross-site scripting vulnerability in ezsystems/ezplatform-admin-ui, published on 17 Oct 2025. An attacker needs administrator access to exploit it, and only if a user opens a file or follows a link."},"fix_prompt":"Check this codebase for GHSA-99c7-c3mw-mxhv and fix it if it is affected.\n\nWhat it is: GHSA-99c7-c3mw-mxhv is a cross-site scripting vulnerability in ezsystems/ezplatform-admin-ui, published on 17 Oct 2025. An attacker needs administrator access to exploit it, and only if a user opens a file or follows a link.\nExploitation: There is no known exploitation of GHSA-99c7-c3mw-mxhv in the wild and no public exploit code.\n\nAffected packages and fixed versions:\n- ezsystems/ezplatform-admin-ui (Packagist): affected from 2.3.0; fixed in 2.3.39\n- ezsystems/ezplatform-admin-ui (Packagist): affected from 2.3.0; fixed in 2.3.39\n\nTask:\n1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.\n2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.\n3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.\n4. Run the tests and summarise what changed and why.\n5. If nothing in the project is affected, say so and change nothing.\n\nReference: https://insights.sbomify.com/GHSA-99c7-c3mw-mxhv/ (Markdown: https://insights.sbomify.com/GHSA-99c7-c3mw-mxhv/index.md)","id":"GHSA-99c7-c3mw-mxhv","markdown":"https://insights.sbomify.com/GHSA-99c7-c3mw-mxhv/index.md","name":"GHSA-99c7-c3mw-mxhv","record":{"aliases":[],"analysis":{"component_type":"web_application","fix_type":"upgrade","impacts":["code_execution","account_takeover"],"network_reachable":"yes","non_default_config":false,"product_category":"Ibexa DXP","requires_auth":"high_privilege","summary":"Persistent XSS in Ibexa DXP back office allows high-privilege users to inject scripts that may affect front-office end users.","user_interaction":"required","vuln_class":"xss"},"analysis_generated_by":"qwen3.8-flash-next","assigner":null,"cpe":[],"cvss":{"score":null,"severity":null,"source":null,"vector":null,"version":null},"cwes":[],"description":"### Impact\nThis security advisory resolves an XSS vulnerability in image asset names, content language names and future publishing in the back office of the DXP. Back office access and varying levels of editing and management permissions are required to exploit this vulnerability. This typically means Editor or Administrator role, or similar. Injected XSS is persistent and may in some cases be reflected in the front office, possibly affecting end users. The fixes ensure XSS is escaped, and any existing injected XSS is rendered harmless.\n\n### Patches\nSee \"Patched versions\".\n\n### Workarounds\nNone.\n\n### References\nhttps://developers.ibexa.co/security-advisories/ibexa-sa-2025-004-xss-and-enumeration-vulnerabilities-in-back-office","ecosystems":["Packagist"],"exploits":{"exploitdb":null,"first_seen":null,"github_poc":null,"max_poc_stars":null,"metasploit":null,"nuclei":null,"refs":[],"tier":null},"has_fix":true,"headline":"ezsystems/ezplatform-admin-ui has an XSS vulnerability in Cancel/Reschedule future publication modal","id":"GHSA-99c7-c3mw-mxhv","indexable":true,"kev":null,"kind":"advisory","links":{"ecosystem":"Packagist","product":null,"products":[],"type":"xss","year":"2025"},"n_packages":2,"n_references":null,"packages":[{"ecosystem":"Packagist","fixed":["2.3.39"],"introduced":["2.3.0"],"last_affected":[],"package":"ezsystems/ezplatform-admin-ui","purl":null,"source":"GHSA-99c7-c3mw-mxhv"},{"ecosystem":"Packagist","fixed":["2.3.39"],"introduced":["2.3.0"],"last_affected":[],"package":"ezsystems/ezplatform-admin-ui","purl":"pkg:composer/ezsystems/ezplatform-admin-ui","source":"GHSA-99c7-c3mw-mxhv"}],"products":null,"published":"2025-10-17","related":[],"sources":[{"class":"attribution","licence":"CC BY 4.0","name":"GitHub Advisory Database","prefix":"GHSA"}],"ssvc":{"automatable":null,"exploitation":null,"technical_impact":null},"state":null,"updated":null,"vendors":null},"summary":"Persistent XSS in Ibexa DXP back office allows high-privilege users to inject scripts that may affect front-office end users.","url":"https://insights.sbomify.com/GHSA-99c7-c3mw-mxhv/"}