# GHSA-9fjq-45qv-pcm7: ruint affected by unsoundness of safe `reciprocal_mg10`

> Attackers can trigger memory corruption in the ruint library via invalid inputs in release builds, potentially leading to code execution or crashes.

- **Severity:** Not scored
- **Exploited in the wild:** Not known
- **Login needed:** Not needed
- **Attackable:** Not stated
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 22 Dec 2025
- **Also known as:** RUSTSEC-2025-0137

## What is GHSA-9fjq-45qv-pcm7?

GHSA-9fjq-45qv-pcm7 is a memory corruption vulnerability in ruint, published on 22 Dec 2025. 

### Official description

The function `reciprocal_mg10` is marked as safe but can trigger undefined behavior (out-of-bounds access) because it relies on `debug_assert!` for safety checks instead of `assert!`.

When compiled in release mode, the `debug_assert!` is optimized out, potentially allowing invalid inputs to cause memory corruption.

## Which versions are affected by GHSA-9fjq-45qv-pcm7?

3 open source packages ship an affected version, including ruint.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `ruint` | crates.io | All versions to 1.17.0 | None |
| `ruint` | crates.io | All versions to 1.17.0 | None |
| `ruint` | crates.io | From 0.0.0-0 | 1.17.1 |

## How do I fix GHSA-9fjq-45qv-pcm7?

Upgrade ruint to 1.17.1 or later.

## Is GHSA-9fjq-45qv-pcm7 being exploited?

There is no known exploitation of GHSA-9fjq-45qv-pcm7 in the wild and no public exploit code.

## Fix prompt for AI coding agents

```text
Check this codebase for GHSA-9fjq-45qv-pcm7 and fix it if it is affected.

What it is: GHSA-9fjq-45qv-pcm7 is a memory corruption vulnerability in ruint, published on 22 Dec 2025. 
Exploitation: There is no known exploitation of GHSA-9fjq-45qv-pcm7 in the wild and no public exploit code.

Affected packages and fixed versions:
- ruint (crates.io): affected all versions up to 1.17.0; no fix listed
- ruint (crates.io): affected all versions up to 1.17.0; no fix listed
- ruint (crates.io): affected from 0.0.0-0; fixed in 1.17.1

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/GHSA-9fjq-45qv-pcm7/ (Markdown: https://insights.sbomify.com/GHSA-9fjq-45qv-pcm7/index.md)
```

## Sources

- OSV: https://osv.dev/vulnerability/GHSA-9fjq-45qv-pcm7

---
From sbomify Insights: https://insights.sbomify.com/GHSA-9fjq-45qv-pcm7/
Summaries are generated and may contain mistakes; the official description above is the record.
