GHSA-9fwj-9mjf-rhj3 laravel-auth0 SDK Vulnerable to Brute Force Authentication Tags of CookieStore Sessions
Attackers can brute force authentication tags in CookieStore sessions to gain unauthorized access to applications using the laravel-auth0 SDK.
- Exploited in the wild
- Not known
- Login needed
- Not needed
- Attackable
- Over the internet
- Victim action needed
- Not needed
- Fix
- Available
What is GHSA-9fwj-9mjf-rhj3?
GHSA-9fwj-9mjf-rhj3 is a vulnerability in auth0/login, published on 17 May 2025. An attacker can exploit it over the internet without logging in, with no action from the victim.
Official description
Overview Session cookies of applications using the laravel-auth0 SDK configured with CookieStore have authentication tags that can be brute forced, which may result in unauthorized access.
Am I Affected? You are affected by this vulnerability if you meet the following pre-conditions:
- Applications using laravel-auth0 SDK with version <=7.16.0
- laravel-auth0 SDK uses the Auth0-PHP SDK with version 8.0.0-BETA1 or higher and below 8.14.0.
- Session storage configured with CookieStore.
Fix Upgrade Auth0/laravel-auth0 to v7.17.0. As an additional precautionary measure, we recommend rotating your cookie encryption keys. Note that once updated, any previous session cookies will be rejected.
Acknowledgement Okta would like to thank Félix Charette for discovering this vulnerability.
Which versions are affected by GHSA-9fwj-9mjf-rhj3?
2 open source packages ship an affected version, including auth0/login.
| Package | Affected | Fixed in |
|---|---|---|
auth0/login Packagist | All versions | 7.17.0 |
auth0/login Packagist | All versions | 7.17.0 |
How do I fix GHSA-9fwj-9mjf-rhj3?
Upgrade auth0/login to 7.17.0 or later.
Is GHSA-9fwj-9mjf-rhj3 being exploited?
There is no known exploitation of GHSA-9fwj-9mjf-rhj3 in the wild and no public exploit code.