{"answers":{"affected":"2 open source packages ship an affected version, including auth0/login.","exploited":"There is no known exploitation of GHSA-9fwj-9mjf-rhj3 in the wild and no public exploit code.","fix":"Upgrade auth0/login to 7.17.0 or later.","what":"GHSA-9fwj-9mjf-rhj3 is a vulnerability in auth0/login, published on 17 May 2025. An attacker can exploit it over the internet without logging in, with no action from the victim."},"fix_prompt":"Check this codebase for GHSA-9fwj-9mjf-rhj3 and fix it if it is affected.\n\nWhat it is: GHSA-9fwj-9mjf-rhj3 is a vulnerability in auth0/login, published on 17 May 2025. An attacker can exploit it over the internet without logging in, with no action from the victim.\nExploitation: There is no known exploitation of GHSA-9fwj-9mjf-rhj3 in the wild and no public exploit code.\n\nAffected packages and fixed versions:\n- auth0/login (Packagist): affected all versions; fixed in 7.17.0\n- auth0/login (Packagist): affected all versions; fixed in 7.17.0\n\nTask:\n1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.\n2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.\n3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.\n4. Run the tests and summarise what changed and why.\n5. If nothing in the project is affected, say so and change nothing.\n\nReference: https://insights.sbomify.com/GHSA-9fwj-9mjf-rhj3/ (Markdown: https://insights.sbomify.com/GHSA-9fwj-9mjf-rhj3/index.md)","id":"GHSA-9fwj-9mjf-rhj3","markdown":"https://insights.sbomify.com/GHSA-9fwj-9mjf-rhj3/index.md","name":"GHSA-9fwj-9mjf-rhj3","record":{"aliases":[],"analysis":{"component_type":"library","fix_type":"upgrade","impacts":["account_takeover"],"network_reachable":"yes","non_default_config":true,"product_category":"Laravel Auth0 SDK","requires_auth":"none","summary":"Attackers can brute force authentication tags in CookieStore sessions to gain unauthorized access to applications using the laravel-auth0 SDK.","user_interaction":"not_required","vuln_class":"weak_cryptography"},"analysis_generated_by":"qwen3.8-flash-next","assigner":null,"cpe":[],"cvss":{"score":null,"severity":null,"source":null,"vector":null,"version":null},"cwes":[],"description":"**Overview**\nSession cookies of applications using the laravel-auth0 SDK configured with CookieStore have authentication tags that can be brute forced, which may result in unauthorized access.\n\n**Am I Affected?**\nYou are affected by this vulnerability if you meet the following pre-conditions:\n1. Applications using laravel-auth0 SDK with version \u003c=7.16.0\n2. laravel-auth0 SDK uses the Auth0-PHP SDK with version 8.0.0-BETA1 or higher and below 8.14.0.  \n3. Session storage configured with CookieStore.\n\n**Fix**\nUpgrade Auth0/laravel-auth0 to v7.17.0. As an additional precautionary measure, we recommend rotating your cookie encryption keys. Note that once updated, any previous session cookies will be rejected.\n\n**Acknowledgement**\nOkta would like to thank Félix Charette for discovering this vulnerability.","ecosystems":["Packagist"],"exploits":{"exploitdb":null,"first_seen":null,"github_poc":null,"max_poc_stars":null,"metasploit":null,"nuclei":null,"refs":[],"tier":null},"has_fix":true,"headline":"laravel-auth0 SDK Vulnerable to Brute Force Authentication Tags of CookieStore Sessions","id":"GHSA-9fwj-9mjf-rhj3","indexable":true,"kev":null,"kind":"advisory","links":{"ecosystem":"Packagist","product":null,"products":[],"type":"weak_cryptography","year":"2025"},"n_packages":2,"n_references":null,"packages":[{"ecosystem":"Packagist","fixed":["7.17.0"],"introduced":["0"],"last_affected":[],"package":"auth0/login","purl":null,"source":"GHSA-9fwj-9mjf-rhj3"},{"ecosystem":"Packagist","fixed":["7.17.0"],"introduced":["0"],"last_affected":[],"package":"auth0/login","purl":"pkg:composer/auth0/login","source":"GHSA-9fwj-9mjf-rhj3"}],"products":null,"published":"2025-05-17","related":[],"sources":[{"class":"attribution","licence":"CC BY 4.0","name":"GitHub Advisory Database","prefix":"GHSA"}],"ssvc":{"automatable":null,"exploitation":null,"technical_impact":null},"state":null,"updated":null,"vendors":null},"summary":"Attackers can brute force authentication tags in CookieStore sessions to gain unauthorized access to applications using the laravel-auth0 SDK.","url":"https://insights.sbomify.com/GHSA-9fwj-9mjf-rhj3/"}