# GHSA-9fwj-9mjf-rhj3: laravel-auth0 SDK Vulnerable to Brute Force Authentication Tags of CookieStore Sessions

> Attackers can brute force authentication tags in CookieStore sessions to gain unauthorized access to applications using the laravel-auth0 SDK.

- **Severity:** Not scored
- **Exploited in the wild:** Not known
- **Login needed:** Not needed
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 17 May 2025

## What is GHSA-9fwj-9mjf-rhj3?

GHSA-9fwj-9mjf-rhj3 is a vulnerability in auth0/login, published on 17 May 2025. An attacker can exploit it over the internet without logging in, with no action from the victim.

### Official description

**Overview**
Session cookies of applications using the laravel-auth0 SDK configured with CookieStore have authentication tags that can be brute forced, which may result in unauthorized access.

**Am I Affected?**
You are affected by this vulnerability if you meet the following pre-conditions:
1. Applications using laravel-auth0 SDK with version <=7.16.0
2. laravel-auth0 SDK uses the Auth0-PHP SDK with version 8.0.0-BETA1 or higher and below 8.14.0.  
3. Session storage configured with CookieStore.

**Fix**
Upgrade Auth0/laravel-auth0 to v7.17.0. As an additional precautionary measure, we recommend rotating your cookie encryption keys. Note that once updated, any previous session cookies will be rejected.

**Acknowledgement**
Okta would like to thank Félix Charette for discovering this vulnerability.

## Which versions are affected by GHSA-9fwj-9mjf-rhj3?

2 open source packages ship an affected version, including auth0/login.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `auth0/login` | Packagist | All versions | 7.17.0 |
| `auth0/login` | Packagist | All versions | 7.17.0 |

## How do I fix GHSA-9fwj-9mjf-rhj3?

Upgrade auth0/login to 7.17.0 or later.

## Is GHSA-9fwj-9mjf-rhj3 being exploited?

There is no known exploitation of GHSA-9fwj-9mjf-rhj3 in the wild and no public exploit code.

## Fix prompt for AI coding agents

```text
Check this codebase for GHSA-9fwj-9mjf-rhj3 and fix it if it is affected.

What it is: GHSA-9fwj-9mjf-rhj3 is a vulnerability in auth0/login, published on 17 May 2025. An attacker can exploit it over the internet without logging in, with no action from the victim.
Exploitation: There is no known exploitation of GHSA-9fwj-9mjf-rhj3 in the wild and no public exploit code.

Affected packages and fixed versions:
- auth0/login (Packagist): affected all versions; fixed in 7.17.0
- auth0/login (Packagist): affected all versions; fixed in 7.17.0

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/GHSA-9fwj-9mjf-rhj3/ (Markdown: https://insights.sbomify.com/GHSA-9fwj-9mjf-rhj3/index.md)
```

## Sources

- OSV: https://osv.dev/vulnerability/GHSA-9fwj-9mjf-rhj3

---
From sbomify Insights: https://insights.sbomify.com/GHSA-9fwj-9mjf-rhj3/
Summaries are generated and may contain mistakes; the official description above is the record.
