# GHSA-9h6g-6mxg-vvp4: Timing side channel vulnerability in endpoint request handler in Vaadin 15-19

> Attackers can bypass CSRF protection in Vaadin Fusion endpoints by exploiting a timing side channel to guess security tokens.

- **Severity:** Not scored
- **Exploited in the wild:** Not known
- **Login needed:** Not needed
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 19 Apr 2021

## What is GHSA-9h6g-6mxg-vvp4?

GHSA-9h6g-6mxg-vvp4 is a vulnerability in com.vaadin:vaadin-bom, published on 19 Apr 2021. An attacker can exploit it over the internet without logging in, with no action from the victim.

### Official description

Non-constant-time comparison of CSRF tokens in endpoint request handler in `com.vaadin:flow-server` versions 3.0.0 through 5.0.3 (Vaadin 15.0.0 through 18.0.6), and com.vaadin:fusion-endpoint version 6.0.0 (Vaadin 19.0.0) allows attacker to guess a security token for Fusion endpoints via timing attack.

- https://vaadin.com/security/cve-2021-31406

## Which versions are affected by GHSA-9h6g-6mxg-vvp4?

4 open source packages ship an affected version, including com.vaadin:vaadin-bom.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `com.vaadin:vaadin-bom` | Maven | From 15.0.0 | 18.0.7 |
| `com.vaadin:vaadin-bom` | Maven | From 15.0.0 | 18.0.7 |
| `com.vaadin:vaadin-bom` | Maven | From 19.0.0 | 19.0.1 |
| `com.vaadin:vaadin-bom` | Maven | From 19.0.0 | 19.0.1 |

## How do I fix GHSA-9h6g-6mxg-vvp4?

Upgrade com.vaadin:vaadin-bom to a fixed version for your release line: 18.0.7 or 19.0.1.

## Is GHSA-9h6g-6mxg-vvp4 being exploited?

There is no known exploitation of GHSA-9h6g-6mxg-vvp4 in the wild and no public exploit code.

## Fix prompt for AI coding agents

```text
Check this codebase for GHSA-9h6g-6mxg-vvp4 and fix it if it is affected.

What it is: GHSA-9h6g-6mxg-vvp4 is a vulnerability in com.vaadin:vaadin-bom, published on 19 Apr 2021. An attacker can exploit it over the internet without logging in, with no action from the victim.
Exploitation: There is no known exploitation of GHSA-9h6g-6mxg-vvp4 in the wild and no public exploit code.

Affected packages and fixed versions:
- com.vaadin:vaadin-bom (Maven): affected from 15.0.0; fixed in 18.0.7
- com.vaadin:vaadin-bom (Maven): affected from 15.0.0; fixed in 18.0.7
- com.vaadin:vaadin-bom (Maven): affected from 19.0.0; fixed in 19.0.1
- com.vaadin:vaadin-bom (Maven): affected from 19.0.0; fixed in 19.0.1

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/GHSA-9h6g-6mxg-vvp4/ (Markdown: https://insights.sbomify.com/GHSA-9h6g-6mxg-vvp4/index.md)
```

## Sources

- OSV: https://osv.dev/vulnerability/GHSA-9h6g-6mxg-vvp4

---
From sbomify Insights: https://insights.sbomify.com/GHSA-9h6g-6mxg-vvp4/
Summaries are generated and may contain mistakes; the official description above is the record.
