{"answers":{"affected":"3 open source packages ship an affected version, including github.com/fkie-cad/yapscan.","exploited":"There is no known exploitation of GHSA-9h6h-9g78-86f7 in the wild and no public exploit code.","fix":"Upgrade github.com/fkie-cad/yapscan to 0.19.1 or later.","what":"GHSA-9h6h-9g78-86f7 is a path traversal vulnerability in github.com/fkie-cad/yapscan, published on 29 Dec 2022. An attacker can exploit it over the internet without logging in, with no action from the victim."},"fix_prompt":"Check this codebase for GHSA-9h6h-9g78-86f7 and fix it if it is affected.\n\nWhat it is: GHSA-9h6h-9g78-86f7 is a path traversal vulnerability in github.com/fkie-cad/yapscan, published on 29 Dec 2022. An attacker can exploit it over the internet without logging in, with no action from the victim.\nExploitation: There is no known exploitation of GHSA-9h6h-9g78-86f7 in the wild and no public exploit code.\n\nAffected packages and fixed versions:\n- github.com/fkie-cad/yapscan (Go): affected from 0.18.0; fixed in 0.19.1\n- github.com/fkie-cad/yapscan (Go): affected from 0.18.0; fixed in 0.19.1\n- github.com/fkie-cad/yapscan (Go): affected from 0.18.0; fixed in 0.19.1\n\nTask:\n1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.\n2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.\n3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.\n4. Run the tests and summarise what changed and why.\n5. If nothing in the project is affected, say so and change nothing.\n\nReference: https://insights.sbomify.com/GHSA-9h6h-9g78-86f7/ (Markdown: https://insights.sbomify.com/GHSA-9h6h-9g78-86f7/index.md)","id":"GHSA-9h6h-9g78-86f7","markdown":"https://insights.sbomify.com/GHSA-9h6h-9g78-86f7/index.md","name":"GHSA-9h6h-9g78-86f7","record":{"aliases":["GO-2022-1204"],"analysis":{"component_type":"server_software","fix_type":"upgrade","impacts":["data_modify"],"network_reachable":"yes","non_default_config":true,"product_category":"Yapscan report receiver","requires_auth":"none","summary":"Attackers can overwrite arbitrary files on the host via path traversal in the experimental report receiver server, leading to data loss.","user_interaction":"not_required","vuln_class":"path_traversal"},"analysis_generated_by":"qwen3.8-flash-next","assigner":null,"cpe":[],"cvss":{"score":null,"severity":null,"source":null,"vector":null,"version":null},"cwes":[],"description":"### Impact\n\nIf you make use of the **report receiver server** (experimental), a client may be able to forge requests such that arbitrary files on the host can be overwritten (subject to permissions of the yapscan server), leading to loss of data. This is particularly problematic if you do not authenticate clients and/or run the server with elevated permissions.\n\n### Patches\n\nVulnerable versions:\n\n- v0.18.0\n- v0.19.0 (unreleased)\n\nThis problem is patched in version v0.19.1\n\n### Workarounds\n\nUpdate to the newer version is highly encouraged!\n\nMeasures to reduce the risk of this include authenticating clients (see `--client-ca` flag) and containerization of the yapscan server.\n\n### References\n\nThe tracking issue is #35. There you can find the commits, fixing the issue.","ecosystems":["Go"],"exploits":{"exploitdb":null,"first_seen":null,"github_poc":null,"max_poc_stars":null,"metasploit":null,"nuclei":null,"refs":[],"tier":null},"has_fix":true,"headline":"Yapscan's report receiver server vulnerable to path traversal and log injection","id":"GHSA-9h6h-9g78-86f7","indexable":true,"kev":null,"kind":"advisory","links":{"ecosystem":"Go","product":null,"products":[],"type":"path_traversal","year":"2022"},"n_packages":3,"n_references":null,"packages":[{"ecosystem":"Go","fixed":["0.19.1"],"introduced":["0.18.0"],"last_affected":[],"package":"github.com/fkie-cad/yapscan","purl":null,"source":"GHSA-9h6h-9g78-86f7"},{"ecosystem":"Go","fixed":["0.19.1"],"introduced":["0.18.0"],"last_affected":[],"package":"github.com/fkie-cad/yapscan","purl":"pkg:golang/github.com/fkie-cad/yapscan","source":"GHSA-9h6h-9g78-86f7"},{"ecosystem":"Go","fixed":["0.19.1"],"introduced":["0.18.0"],"last_affected":[],"package":"github.com/fkie-cad/yapscan","purl":"pkg:golang/github.com/fkie-cad/yapscan","source":"GO-2022-1204"}],"products":null,"published":"2022-12-29","related":[],"sources":[{"class":"attribution","licence":"CC BY 4.0","name":"GitHub Advisory Database","prefix":"GHSA"},{"class":"attribution","licence":"CC BY 4.0","name":"Go Vulnerability Database","prefix":"GO"}],"ssvc":{"automatable":null,"exploitation":null,"technical_impact":null},"state":null,"updated":null,"vendors":null},"summary":"Attackers can overwrite arbitrary files on the host via path traversal in the experimental report receiver server, leading to data loss.","url":"https://insights.sbomify.com/GHSA-9h6h-9g78-86f7/"}