{"answers":{"affected":"2 open source packages ship an affected version, including openmage/magento-lts.","exploited":"There is no known exploitation of GHSA-9j5w-2cqc-cwj9 in the wild and no public exploit code.","fix":"Upgrade openmage/magento-lts to 20.2.0 or later.","what":"GHSA-9j5w-2cqc-cwj9 is a cross-site scripting vulnerability in openmage/magento-lts, published on 8 Dec 2023. Any signed-in user can exploit it over the network, and only if a user opens a file or follows a link."},"fix_prompt":"Check this codebase for GHSA-9j5w-2cqc-cwj9 and fix it if it is affected.\n\nWhat it is: GHSA-9j5w-2cqc-cwj9 is a cross-site scripting vulnerability in openmage/magento-lts, published on 8 Dec 2023. Any signed-in user can exploit it over the network, and only if a user opens a file or follows a link.\nExploitation: There is no known exploitation of GHSA-9j5w-2cqc-cwj9 in the wild and no public exploit code.\n\nAffected packages and fixed versions:\n- openmage/magento-lts (Packagist): affected all versions; fixed in 20.2.0\n- openmage/magento-lts (Packagist): affected all versions; fixed in 20.2.0\n\nTask:\n1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.\n2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.\n3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.\n4. Run the tests and summarise what changed and why.\n5. If nothing in the project is affected, say so and change nothing.\n\nReference: https://insights.sbomify.com/GHSA-9j5w-2cqc-cwj9/ (Markdown: https://insights.sbomify.com/GHSA-9j5w-2cqc-cwj9/index.md)","id":"GHSA-9j5w-2cqc-cwj9","markdown":"https://insights.sbomify.com/GHSA-9j5w-2cqc-cwj9/index.md","name":"GHSA-9j5w-2cqc-cwj9","record":{"aliases":[],"analysis":{"component_type":"web_application","fix_type":"upgrade","impacts":["code_execution","account_takeover"],"network_reachable":"yes","non_default_config":false,"product_category":"Magento LTS","requires_auth":"low_privilege","summary":"Stored XSS in Magento LTS TinyMCE editor allows attackers to execute scripts in victim browsers, potentially leading to account takeover.","user_interaction":"required","vuln_class":"xss"},"analysis_generated_by":"qwen3.8-flash-next","assigner":null,"cpe":[],"cvss":{"score":null,"severity":null,"source":null,"vector":null,"version":null},"cwes":[],"description":"From HackerOne report [#1948040](https://hackerone.com/reports/1948040) by Halit AKAYDIN (hltakydn)\n\n### Impact\n_What kind of vulnerability is it? Who is impacted?_\n\nThe TinyMCE WYSIWYG editor fails to filter scripts when rendering the HTML in specially crafted HTML tags.\n\n### Patches\n_Has the problem been patched? What versions should users upgrade to?_\n\nThis vulnerability was fixed in version 20.2.0 by upgrading TinyMCE to a recent version in https://github.com/OpenMage/magento-lts/pull/3220\n\n### Workarounds\n_Is there a way for users to fix or remediate the vulnerability without upgrading?_\n\nThe WYSIWYG editor features could be disabled in the configuration. Possibly some WAF appliances would filter this attack.\n\n### References\n_Are there any links users can visit to find out more?_\n\nThe attack is simply an exploit of the \"onmouseover\" attribute of an `img` element as described on [OWASP XSS Filter Evasion](https://cheatsheetseries.owasp.org/cheatsheets/XSS_Filter_Evasion_Cheat_Sheet.html)","ecosystems":["Packagist"],"exploits":{"exploitdb":null,"first_seen":null,"github_poc":null,"max_poc_stars":null,"metasploit":null,"nuclei":null,"refs":[],"tier":null},"has_fix":true,"headline":"Magento LTS vulnerable to Stored XSS via TinyMCE WYSIWYG Editor","id":"GHSA-9j5w-2cqc-cwj9","indexable":true,"kev":null,"kind":"advisory","links":{"ecosystem":"Packagist","product":null,"products":[],"type":"xss","year":"2023"},"n_packages":2,"n_references":null,"packages":[{"ecosystem":"Packagist","fixed":["20.2.0"],"introduced":["0"],"last_affected":[],"package":"openmage/magento-lts","purl":null,"source":"GHSA-9j5w-2cqc-cwj9"},{"ecosystem":"Packagist","fixed":["20.2.0"],"introduced":["0"],"last_affected":[],"package":"openmage/magento-lts","purl":"pkg:composer/openmage/magento-lts","source":"GHSA-9j5w-2cqc-cwj9"}],"products":null,"published":"2023-12-08","related":[],"sources":[{"class":"attribution","licence":"CC BY 4.0","name":"GitHub Advisory Database","prefix":"GHSA"}],"ssvc":{"automatable":null,"exploitation":null,"technical_impact":null},"state":null,"updated":null,"vendors":null},"summary":"Stored XSS in Magento LTS TinyMCE editor allows attackers to execute scripts in victim browsers, potentially leading to account takeover.","url":"https://insights.sbomify.com/GHSA-9j5w-2cqc-cwj9/"}