# GHSA-9m65-766c-r333: A type-confusion bug in seroval ≤ 1.5.2 ([upstream advisory](https://github.com/lxsmnsyc/seroval/security/advisories)) allowed a

> A deserialization flaw in TanStack Start allows triggering unintended server functions, though impact is limited to logging anomalies in correctly configured apps.

- **Severity:** Not scored
- **Exploited in the wild:** Not known
- **Login needed:** Not needed
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 14 May 2026

## What is GHSA-9m65-766c-r333?

GHSA-9m65-766c-r333 is an unsafe deserialization vulnerability in @tanstack/start-server-core, published on 14 May 2026. An attacker can exploit it over the internet without logging in, with no action from the victim.

### Official description

### Summary
A type-confusion bug in seroval ≤ 1.5.2 ([upstream advisory](https://github.com/lxsmnsyc/seroval/security/advisories)) allowed a crafted JSON body sent to one TanStack Start server function to trigger invocation of a different client-referenced server function as a side effect of deserializing the request payload.

This is not an authentication bypass and not remote code execution. The mechanism only invokes server functions that the same client could already reach directly via /_serverFn/<id>, and the target function's full middleware chain — including any user-supplied authentication, authorization, and inputValidator — runs as it would on a direct call.

### Impact
To be exploitable in any meaningful sense, an application would need to expose a client-referenced server function that:

- [ ] Performs a privileged side effect, and
- [ ] Has no authentication/authorization middleware, and
- [ ] Has no input validation

A function meeting all three is already directly callable by any unauthenticated client at its own endpoint, so the practical impact on correctly-written applications is nil. The residual concerns are:

A request to function A could cause function B to also execute, which may surprise observability/audit logging that keys off the request URL.

Request-level middleware (as opposed to per-function middleware) does not re-run for the inner invocation.
Server-only functions (isClientReferenced: false) cannot be reached through this mechanism.

### Patches
Upgrade to @tanstack/start-server-core ≥ 1.167.30 (or the equivalent dated release of @tanstack/react-start / @tanstack/solid-start). The fix bumps seroval to ≥ 1.5.3 and adds defense-in-depth to the serialization adapter plugin shape so adapter payloads cannot be confused with internal seroval node types.

### Workarounds
If you cannot upgrade immediately, ensure every createServerFn(...) exposed to the client has both an .inputValidator(...) and authentication/authorization middleware via .middleware([...]). This is recommended regardless of this advisory.

### Credits
- [Mufeed VH](https://x.com/mufeedvh) of [Winfunc Research](https://winfunc.com/)
- Upstream fix coordinated with Seroval maintainers https://github.com/lxsmnsyc/seroval

## Which versions are affected by GHSA-9m65-766c-r333?

2 open source packages ship an affected version, including @tanstack/start-server-core.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `@tanstack/start-server-core` | npm | All versions | 1.167.30 |
| `@tanstack/start-server-core` | npm | All versions | 1.167.30 |

## How do I fix GHSA-9m65-766c-r333?

Upgrade @tanstack/start-server-core to 1.167.30 or later.

## Is GHSA-9m65-766c-r333 being exploited?

There is no known exploitation of GHSA-9m65-766c-r333 in the wild and no public exploit code.

## Fix prompt for AI coding agents

```text
Check this codebase for GHSA-9m65-766c-r333 and fix it if it is affected.

What it is: GHSA-9m65-766c-r333 is an unsafe deserialization vulnerability in @tanstack/start-server-core, published on 14 May 2026. An attacker can exploit it over the internet without logging in, with no action from the victim.
Exploitation: There is no known exploitation of GHSA-9m65-766c-r333 in the wild and no public exploit code.

Affected packages and fixed versions:
- @tanstack/start-server-core (npm): affected all versions; fixed in 1.167.30
- @tanstack/start-server-core (npm): affected all versions; fixed in 1.167.30

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/GHSA-9m65-766c-r333/ (Markdown: https://insights.sbomify.com/GHSA-9m65-766c-r333/index.md)
```

## Sources

- OSV: https://osv.dev/vulnerability/GHSA-9m65-766c-r333

---
From sbomify Insights: https://insights.sbomify.com/GHSA-9m65-766c-r333/
Summaries are generated and may contain mistakes; the official description above is the record.
