GHSA-9q64-mpxx-87fg Open Redirect in ecstatic
Attackers can craft requests causing HTTP 301 redirects to arbitrary domains, potentially facilitating phishing attacks against users of the ecstatic library.
- Exploited in the wild
- Not known
- Login needed
- Not needed
- Attackable
- Over the internet
- Victim action needed
- A user has to click or open something
- Fix
- Available
What is GHSA-9q64-mpxx-87fg?
GHSA-9q64-mpxx-87fg is a vulnerability in ecstatic, published on 1 Apr 2020. An attacker can exploit it over the internet without logging in, and only if a user opens a file or follows a link.
Official description
Versions of ecstatic prior to 4.1.2, 3.3.2 or 2.2.2 are vulnerable to Open Redirect. The package fails to validate redirects, allowing attackers to craft requests that result in an HTTP 301 redirect to any other domains.
Recommendation
If using ecstatic 4.x, upgrade to 4.1.2 or later.
If using ecstatic 3.x, upgrade to 3.3.2 or later.
If using ecstatic 2.x, upgrade to 2.2.2 or later.
Which versions are affected by GHSA-9q64-mpxx-87fg?
6 open source packages ship an affected version, including ecstatic.
| Package | Affected | Fixed in |
|---|---|---|
ecstatic npm | All versions | 2.2.2 |
ecstatic npm | All versions | 2.2.2 |
ecstatic npm | From 3.0.0 | 3.3.2 |
ecstatic npm | From 3.0.0 | 3.3.2 |
ecstatic npm | From 4.0.0 | 4.1.2 |
ecstatic npm | From 4.0.0 | 4.1.2 |
How do I fix GHSA-9q64-mpxx-87fg?
Upgrade ecstatic to a fixed version for your release line: 2.2.2, 3.3.2 or 4.1.2.
Is GHSA-9q64-mpxx-87fg being exploited?
There is no known exploitation of GHSA-9q64-mpxx-87fg in the wild and no public exploit code.