{"answers":{"affected":"6 open source packages ship an affected version, including ecstatic.","exploited":"There is no known exploitation of GHSA-9q64-mpxx-87fg in the wild and no public exploit code.","fix":"Upgrade ecstatic to a fixed version for your release line: 2.2.2, 3.3.2 or 4.1.2.","what":"GHSA-9q64-mpxx-87fg is a vulnerability in ecstatic, published on 1 Apr 2020. An attacker can exploit it over the internet without logging in, and only if a user opens a file or follows a link."},"fix_prompt":"Check this codebase for GHSA-9q64-mpxx-87fg and fix it if it is affected.\n\nWhat it is: GHSA-9q64-mpxx-87fg is a vulnerability in ecstatic, published on 1 Apr 2020. An attacker can exploit it over the internet without logging in, and only if a user opens a file or follows a link.\nExploitation: There is no known exploitation of GHSA-9q64-mpxx-87fg in the wild and no public exploit code.\n\nAffected packages and fixed versions:\n- ecstatic (npm): affected all versions; fixed in 2.2.2\n- ecstatic (npm): affected all versions; fixed in 2.2.2\n- ecstatic (npm): affected from 3.0.0; fixed in 3.3.2\n- ecstatic (npm): affected from 3.0.0; fixed in 3.3.2\n- ecstatic (npm): affected from 4.0.0; fixed in 4.1.2\n- ecstatic (npm): affected from 4.0.0; fixed in 4.1.2\n\nTask:\n1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.\n2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.\n3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.\n4. Run the tests and summarise what changed and why.\n5. If nothing in the project is affected, say so and change nothing.\n\nReference: https://insights.sbomify.com/GHSA-9q64-mpxx-87fg/ (Markdown: https://insights.sbomify.com/GHSA-9q64-mpxx-87fg/index.md)","id":"GHSA-9q64-mpxx-87fg","markdown":"https://insights.sbomify.com/GHSA-9q64-mpxx-87fg/index.md","name":"GHSA-9q64-mpxx-87fg","record":{"aliases":[],"analysis":{"component_type":"library","fix_type":"upgrade","impacts":["security_bypass"],"network_reachable":"yes","non_default_config":false,"product_category":"Node.js static file server","requires_auth":"none","summary":"Attackers can craft requests causing HTTP 301 redirects to arbitrary domains, potentially facilitating phishing attacks against users of the ecstatic library.","user_interaction":"required","vuln_class":"open_redirect"},"analysis_generated_by":"qwen3.8-flash-next","assigner":null,"cpe":[],"cvss":{"score":null,"severity":null,"source":null,"vector":null,"version":null},"cwes":[],"description":"Versions of `ecstatic` prior to 4.1.2, 3.3.2 or 2.2.2 are vulnerable to Open Redirect. The package fails to validate redirects, allowing attackers to craft requests that result in an `HTTP 301` redirect to any other domains.\n\n## Recommendation\n\nIf using `ecstatic` 4.x, upgrade to 4.1.2 or later.\nIf using `ecstatic` 3.x, upgrade to 3.3.2 or later.\nIf using `ecstatic` 2.x, upgrade to 2.2.2 or later.","ecosystems":["npm"],"exploits":{"exploitdb":null,"first_seen":null,"github_poc":null,"max_poc_stars":null,"metasploit":null,"nuclei":null,"refs":[],"tier":null},"has_fix":true,"headline":"Open Redirect in ecstatic","id":"GHSA-9q64-mpxx-87fg","indexable":true,"kev":null,"kind":"advisory","links":{"ecosystem":"npm","product":null,"products":[],"type":"open_redirect","year":"2020"},"n_packages":6,"n_references":null,"packages":[{"ecosystem":"npm","fixed":["2.2.2"],"introduced":["0"],"last_affected":[],"package":"ecstatic","purl":null,"source":"GHSA-9q64-mpxx-87fg"},{"ecosystem":"npm","fixed":["2.2.2"],"introduced":["0"],"last_affected":[],"package":"ecstatic","purl":"pkg:npm/ecstatic","source":"GHSA-9q64-mpxx-87fg"},{"ecosystem":"npm","fixed":["3.3.2"],"introduced":["3.0.0"],"last_affected":[],"package":"ecstatic","purl":null,"source":"GHSA-9q64-mpxx-87fg"},{"ecosystem":"npm","fixed":["3.3.2"],"introduced":["3.0.0"],"last_affected":[],"package":"ecstatic","purl":"pkg:npm/ecstatic","source":"GHSA-9q64-mpxx-87fg"},{"ecosystem":"npm","fixed":["4.1.2"],"introduced":["4.0.0"],"last_affected":[],"package":"ecstatic","purl":null,"source":"GHSA-9q64-mpxx-87fg"},{"ecosystem":"npm","fixed":["4.1.2"],"introduced":["4.0.0"],"last_affected":[],"package":"ecstatic","purl":"pkg:npm/ecstatic","source":"GHSA-9q64-mpxx-87fg"}],"products":null,"published":"2020-04-01","related":[],"sources":[{"class":"attribution","licence":"CC BY 4.0","name":"GitHub Advisory Database","prefix":"GHSA"}],"ssvc":{"automatable":null,"exploitation":null,"technical_impact":null},"state":null,"updated":null,"vendors":null},"summary":"Attackers can craft requests causing HTTP 301 redirects to arbitrary domains, potentially facilitating phishing attacks against users of the ecstatic library.","url":"https://insights.sbomify.com/GHSA-9q64-mpxx-87fg/"}