# GHSA-9q64-mpxx-87fg: Open Redirect in ecstatic

> Attackers can craft requests causing HTTP 301 redirects to arbitrary domains, potentially facilitating phishing attacks against users of the ecstatic library.

- **Severity:** Not scored
- **Exploited in the wild:** Not known
- **Login needed:** Not needed
- **Attackable:** Over the internet
- **Victim action needed:** A user has to click or open something
- **Fix available:** Yes
- **Published:** 1 Apr 2020

## What is GHSA-9q64-mpxx-87fg?

GHSA-9q64-mpxx-87fg is a vulnerability in ecstatic, published on 1 Apr 2020. An attacker can exploit it over the internet without logging in, and only if a user opens a file or follows a link.

### Official description

Versions of `ecstatic` prior to 4.1.2, 3.3.2 or 2.2.2 are vulnerable to Open Redirect. The package fails to validate redirects, allowing attackers to craft requests that result in an `HTTP 301` redirect to any other domains.

## Recommendation

If using `ecstatic` 4.x, upgrade to 4.1.2 or later.
If using `ecstatic` 3.x, upgrade to 3.3.2 or later.
If using `ecstatic` 2.x, upgrade to 2.2.2 or later.

## Which versions are affected by GHSA-9q64-mpxx-87fg?

6 open source packages ship an affected version, including ecstatic.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `ecstatic` | npm | All versions | 2.2.2 |
| `ecstatic` | npm | All versions | 2.2.2 |
| `ecstatic` | npm | From 3.0.0 | 3.3.2 |
| `ecstatic` | npm | From 3.0.0 | 3.3.2 |
| `ecstatic` | npm | From 4.0.0 | 4.1.2 |
| `ecstatic` | npm | From 4.0.0 | 4.1.2 |

## How do I fix GHSA-9q64-mpxx-87fg?

Upgrade ecstatic to a fixed version for your release line: 2.2.2, 3.3.2 or 4.1.2.

## Is GHSA-9q64-mpxx-87fg being exploited?

There is no known exploitation of GHSA-9q64-mpxx-87fg in the wild and no public exploit code.

## Fix prompt for AI coding agents

```text
Check this codebase for GHSA-9q64-mpxx-87fg and fix it if it is affected.

What it is: GHSA-9q64-mpxx-87fg is a vulnerability in ecstatic, published on 1 Apr 2020. An attacker can exploit it over the internet without logging in, and only if a user opens a file or follows a link.
Exploitation: There is no known exploitation of GHSA-9q64-mpxx-87fg in the wild and no public exploit code.

Affected packages and fixed versions:
- ecstatic (npm): affected all versions; fixed in 2.2.2
- ecstatic (npm): affected all versions; fixed in 2.2.2
- ecstatic (npm): affected from 3.0.0; fixed in 3.3.2
- ecstatic (npm): affected from 3.0.0; fixed in 3.3.2
- ecstatic (npm): affected from 4.0.0; fixed in 4.1.2
- ecstatic (npm): affected from 4.0.0; fixed in 4.1.2

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/GHSA-9q64-mpxx-87fg/ (Markdown: https://insights.sbomify.com/GHSA-9q64-mpxx-87fg/index.md)
```

## Sources

- OSV: https://osv.dev/vulnerability/GHSA-9q64-mpxx-87fg

---
From sbomify Insights: https://insights.sbomify.com/GHSA-9q64-mpxx-87fg/
Summaries are generated and may contain mistakes; the official description above is the record.
