{"answers":{"affected":"2 open source packages ship an affected version, including node-sass.","exploited":"There is no known exploitation of GHSA-9v62-24cr-58cx in the wild and no public exploit code.","fix":"Upgrade node-sass to 4.13.1 or later.","what":"GHSA-9v62-24cr-58cx is a vulnerability in node-sass, published on 11 Sep 2020."},"fix_prompt":"Check this codebase for GHSA-9v62-24cr-58cx and fix it if it is affected.\n\nWhat it is: GHSA-9v62-24cr-58cx is a vulnerability in node-sass, published on 11 Sep 2020. \nExploitation: There is no known exploitation of GHSA-9v62-24cr-58cx in the wild and no public exploit code.\n\nAffected packages and fixed versions:\n- node-sass (npm): affected from 3.3.0; fixed in 4.13.1\n- node-sass (npm): affected from 3.3.0; fixed in 4.13.1\n\nTask:\n1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.\n2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.\n3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.\n4. Run the tests and summarise what changed and why.\n5. If nothing in the project is affected, say so and change nothing.\n\nReference: https://insights.sbomify.com/GHSA-9v62-24cr-58cx/ (Markdown: https://insights.sbomify.com/GHSA-9v62-24cr-58cx/index.md)","id":"GHSA-9v62-24cr-58cx","markdown":"https://insights.sbomify.com/GHSA-9v62-24cr-58cx/index.md","name":"GHSA-9v62-24cr-58cx","record":{"aliases":[],"analysis":null,"analysis_generated_by":null,"assigner":null,"cpe":[],"cvss":{"score":null,"severity":null,"source":null,"vector":null,"version":null},"cwes":[],"description":"Affected versions of `node-sass` are vulnerable to Denial of Service (DoS). Crafted objects passed to the `renderSync` function may trigger C++ assertions in `CustomImporterBridge::get_importer_entry` and `CustomImporterBridge::post_process_return_value` that crash the Node process. This may allow attackers to crash the system's running Node process and lead to Denial of Service.\n\n## Recommendation\n\nUpgrade to version 4.13.1 or later","ecosystems":["npm"],"exploits":{"exploitdb":null,"first_seen":null,"github_poc":null,"max_poc_stars":null,"metasploit":null,"nuclei":null,"refs":[],"tier":null},"has_fix":true,"headline":"Denial of Service in node-sass","id":"GHSA-9v62-24cr-58cx","indexable":true,"kev":null,"kind":"advisory","links":{"ecosystem":"npm","product":null,"products":[],"type":null,"year":"2020"},"n_packages":2,"n_references":null,"packages":[{"ecosystem":"npm","fixed":["4.13.1"],"introduced":["3.3.0"],"last_affected":[],"package":"node-sass","purl":null,"source":"GHSA-9v62-24cr-58cx"},{"ecosystem":"npm","fixed":["4.13.1"],"introduced":["3.3.0"],"last_affected":[],"package":"node-sass","purl":"pkg:npm/node-sass","source":"GHSA-9v62-24cr-58cx"}],"products":null,"published":"2020-09-11","related":[],"sources":[{"class":"attribution","licence":"CC BY 4.0","name":"GitHub Advisory Database","prefix":"GHSA"}],"ssvc":{"automatable":null,"exploitation":null,"technical_impact":null},"state":null,"updated":null,"vendors":null},"summary":null,"url":"https://insights.sbomify.com/GHSA-9v62-24cr-58cx/"}