{"answers":{"affected":"4 open source packages ship an affected version, including shopware/core and shopware/shopware.","exploited":"There is no known exploitation of GHSA-9v82-vcjx-m76j in the wild and no public exploit code.","fix":"Upgrade shopware/core to 6.7.2.1 or later.","what":"GHSA-9v82-vcjx-m76j is a cross-site scripting vulnerability in shopware/core, published on 10 Sep 2025. An attacker can exploit it over the internet without logging in, and only if a user opens a file or follows a link."},"fix_prompt":"Check this codebase for GHSA-9v82-vcjx-m76j and fix it if it is affected.\n\nWhat it is: GHSA-9v82-vcjx-m76j is a cross-site scripting vulnerability in shopware/core, published on 10 Sep 2025. An attacker can exploit it over the internet without logging in, and only if a user opens a file or follows a link.\nExploitation: There is no known exploitation of GHSA-9v82-vcjx-m76j in the wild and no public exploit code.\n\nAffected packages and fixed versions:\n- shopware/core (Packagist): affected from 6.7.0.0; fixed in 6.7.2.1\n- shopware/core (Packagist): affected from 6.7.0.0; fixed in 6.7.2.1\n- shopware/shopware (Packagist): affected from 6.7.0.0; fixed in 6.7.2.1\n- shopware/shopware (Packagist): affected from 6.7.0.0; fixed in 6.7.2.1\n\nTask:\n1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.\n2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.\n3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.\n4. Run the tests and summarise what changed and why.\n5. If nothing in the project is affected, say so and change nothing.\n\nReference: https://insights.sbomify.com/GHSA-9v82-vcjx-m76j/ (Markdown: https://insights.sbomify.com/GHSA-9v82-vcjx-m76j/index.md)","id":"GHSA-9v82-vcjx-m76j","markdown":"https://insights.sbomify.com/GHSA-9v82-vcjx-m76j/index.md","name":"GHSA-9v82-vcjx-m76j","record":{"aliases":[],"analysis":{"component_type":"web_application","fix_type":"patch","impacts":["account_takeover","privilege_escalation"],"network_reachable":"yes","non_default_config":false,"product_category":"Shopware e-commerce platform","requires_auth":"none","summary":"Attackers can inject malicious scripts via URL parameters to steal session cookies and admin tokens, requiring user interaction to execute.","user_interaction":"required","vuln_class":"xss"},"analysis_generated_by":"qwen3.8-flash-next","assigner":null,"cpe":[],"cvss":{"score":null,"severity":null,"source":null,"vector":null,"version":null},"cwes":[],"description":"### Impact\nBy exploiting XSS vulnerabilities, malicious actors can perform harmful actions in the user's web browser in the session context of the affected user. \n\nSome examples of this include, but are not limited to:\n- Obtaining user session tokens.\n- Performing administrative actions (when an administrative user is affected).\n\nThese vulnerabilities pose a high security risk. Since a sensitive cookie is not configured with the HttpOnly attribute and administrator JWTs are stored in sessionStorage, any successful XSS attack could enable the theft of session cookies and administrative tokens.\n\n#### Description\nWhen an application uses input fields, it is important that user input is adequately filtered for malicious HTML and JavaScript characters. When adequate input validation is not applied, Cross-Site Scripting (XSS) vulnerabilities may arise. These allow malicious actors to inject malicious code into application pages. When a user visits the page, the code is executed in the user's web browser. This allows malicious actors to perform malicious actions in the name of that user. XSS can be divided into three variants: Persistent XSS, Reflective XSS and DOM-based XSS. In Reflective XSS, a malicious actor injects malicious JavaScript code into a URL. Every time the user visits this URL, the JavaScript code is executed in the user’s browser.\n\n#### Applicability \nDue to a lack of input validation, the Shopware application contain XSS vulnerabilities. The JavaScript variable 'activeRouteParameters' lacks input validation, which makes it vulnerable to XSS attacks at the following endpoints:\n\n- /page/cms/*\n- /widget/cms/*\n\nThe lack of input validation enables malicious actors to inject harmful JavaScript-code into the affected pages. When a user visits the page, the code is executed within the user’s web browser. This enables malicious actors to perform (harmful) actions on behalf of the affected user. No user account is required to exploit this vulnerability.\n\n#### Reproduction\nTo reproduce this vulnerability, the steps below can be followed.\n1. Navigate to the URL below containing the XSS payload:\nhttps://pentest-saas-2025-2.shopware.store/page/cms/'+alert('REQON')+'\n2. Observe that a pop-up is shown indicating that the JavaScript code has been executed.\n\n#### Workarounds\nFor older versions of 6.7, corresponding security measures are also available via a plugin. For the full range of functions, we recommend updating to the latest Shopware version.","ecosystems":["Packagist"],"exploits":{"exploitdb":null,"first_seen":null,"github_poc":null,"max_poc_stars":null,"metasploit":null,"nuclei":null,"refs":[],"tier":null},"has_fix":true,"headline":"Shopware: Reflective Cross Site-Scripting (XSS) in CMS components","id":"GHSA-9v82-vcjx-m76j","indexable":true,"kev":null,"kind":"advisory","links":{"ecosystem":"Packagist","product":null,"products":[],"type":"xss","year":"2025"},"n_packages":4,"n_references":null,"packages":[{"ecosystem":"Packagist","fixed":["6.7.2.1"],"introduced":["6.7.0.0"],"last_affected":[],"package":"shopware/core","purl":null,"source":"GHSA-9v82-vcjx-m76j"},{"ecosystem":"Packagist","fixed":["6.7.2.1"],"introduced":["6.7.0.0"],"last_affected":[],"package":"shopware/core","purl":"pkg:composer/shopware/core","source":"GHSA-9v82-vcjx-m76j"},{"ecosystem":"Packagist","fixed":["6.7.2.1"],"introduced":["6.7.0.0"],"last_affected":[],"package":"shopware/shopware","purl":null,"source":"GHSA-9v82-vcjx-m76j"},{"ecosystem":"Packagist","fixed":["6.7.2.1"],"introduced":["6.7.0.0"],"last_affected":[],"package":"shopware/shopware","purl":"pkg:composer/shopware/shopware","source":"GHSA-9v82-vcjx-m76j"}],"products":null,"published":"2025-09-10","related":[],"sources":[{"class":"attribution","licence":"CC BY 4.0","name":"GitHub Advisory Database","prefix":"GHSA"}],"ssvc":{"automatable":null,"exploitation":null,"technical_impact":null},"state":null,"updated":null,"vendors":null},"summary":"Attackers can inject malicious scripts via URL parameters to steal session cookies and admin tokens, requiring user interaction to execute.","url":"https://insights.sbomify.com/GHSA-9v82-vcjx-m76j/"}