{"answers":{"affected":"2 open source packages ship an affected version, including shopware/shopware.","exploited":"There is no known exploitation of GHSA-9vxv-wpv4-f52p in the wild and no public exploit code.","fix":"Upgrade shopware/shopware to 5.6.10 or later.","what":"GHSA-9vxv-wpv4-f52p is a vulnerability in shopware/shopware, published on 21 May 2021. It can be exploited over the network."},"fix_prompt":"Check this codebase for GHSA-9vxv-wpv4-f52p and fix it if it is affected.\n\nWhat it is: GHSA-9vxv-wpv4-f52p is a vulnerability in shopware/shopware, published on 21 May 2021. It can be exploited over the network.\nExploitation: There is no known exploitation of GHSA-9vxv-wpv4-f52p in the wild and no public exploit code.\n\nAffected packages and fixed versions:\n- shopware/shopware (Packagist): affected all versions; fixed in 5.6.10\n- shopware/shopware (Packagist): affected all versions; fixed in 5.6.10\n\nTask:\n1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.\n2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.\n3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.\n4. Run the tests and summarise what changed and why.\n5. If nothing in the project is affected, say so and change nothing.\n\nReference: https://insights.sbomify.com/GHSA-9vxv-wpv4-f52p/ (Markdown: https://insights.sbomify.com/GHSA-9vxv-wpv4-f52p/index.md)","id":"GHSA-9vxv-wpv4-f52p","markdown":"https://insights.sbomify.com/GHSA-9vxv-wpv4-f52p/index.md","name":"GHSA-9vxv-wpv4-f52p","record":{"aliases":[],"analysis":{"component_type":"web_application","fix_type":"upgrade","impacts":["data_read"],"network_reachable":"yes","non_default_config":false,"product_category":"Shopware e-commerce platform","requires_auth":"unknown","summary":"An information leakage vulnerability in the Error Handler allows attackers to access sensitive data, requiring an upgrade to the latest version.","user_interaction":"unknown","vuln_class":"information_disclosure"},"analysis_generated_by":"qwen3.8-flash-next","assigner":null,"cpe":[],"cvss":{"score":null,"severity":null,"source":null,"vector":null,"version":null},"cwes":[],"description":"### Impact\nInformation leakage in Error Handler\n\n### Patches\nWe recommend updating to the current version 5.6.10. You can get the update to 5.6.10 regularly via the Auto-Updater or directly via the download overview.\n\nFor older versions you can use the Security Plugin:\nhttps://store.shopware.com/en/swag575294366635f/shopware-security-plugin.html\n\n### References\nhttps://docs.shopware.com/en/shopware-5-en/security-updates/security-update-05-2021","ecosystems":["Packagist"],"exploits":{"exploitdb":null,"first_seen":null,"github_poc":null,"max_poc_stars":null,"metasploit":null,"nuclei":null,"refs":[],"tier":null},"has_fix":true,"headline":"Information leakage in Error Handler","id":"GHSA-9vxv-wpv4-f52p","indexable":true,"kev":null,"kind":"advisory","links":{"ecosystem":"Packagist","product":null,"products":[],"type":"information_disclosure","year":"2021"},"n_packages":2,"n_references":null,"packages":[{"ecosystem":"Packagist","fixed":["5.6.10"],"introduced":["0"],"last_affected":[],"package":"shopware/shopware","purl":null,"source":"GHSA-9vxv-wpv4-f52p"},{"ecosystem":"Packagist","fixed":["5.6.10"],"introduced":["0"],"last_affected":[],"package":"shopware/shopware","purl":"pkg:composer/shopware/shopware","source":"GHSA-9vxv-wpv4-f52p"}],"products":null,"published":"2021-05-21","related":[],"sources":[{"class":"attribution","licence":"CC BY 4.0","name":"GitHub Advisory Database","prefix":"GHSA"}],"ssvc":{"automatable":null,"exploitation":null,"technical_impact":null},"state":null,"updated":null,"vendors":null},"summary":"An information leakage vulnerability in the Error Handler allows attackers to access sensitive data, requiring an upgrade to the latest version.","url":"https://insights.sbomify.com/GHSA-9vxv-wpv4-f52p/"}