{"answers":{"affected":"2 open source packages ship an affected version, including graphql-code-generator.","exploited":"There is no known exploitation of GHSA-9w87-4j72-gcv7 in the wild and no public exploit code.","fix":"Upgrade graphql-code-generator to 0.18.2 or later.","what":"GHSA-9w87-4j72-gcv7 is a vulnerability in graphql-code-generator, published on 2 Sep 2020. An attacker can exploit it over the internet without logging in, with no action from the victim."},"fix_prompt":"Check this codebase for GHSA-9w87-4j72-gcv7 and fix it if it is affected.\n\nWhat it is: GHSA-9w87-4j72-gcv7 is a vulnerability in graphql-code-generator, published on 2 Sep 2020. An attacker can exploit it over the internet without logging in, with no action from the victim.\nExploitation: There is no known exploitation of GHSA-9w87-4j72-gcv7 in the wild and no public exploit code.\n\nAffected packages and fixed versions:\n- graphql-code-generator (npm): affected all versions; fixed in 0.18.2\n- graphql-code-generator (npm): affected all versions; fixed in 0.18.2\n\nTask:\n1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.\n2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.\n3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.\n4. Run the tests and summarise what changed and why.\n5. If nothing in the project is affected, say so and change nothing.\n\nReference: https://insights.sbomify.com/GHSA-9w87-4j72-gcv7/ (Markdown: https://insights.sbomify.com/GHSA-9w87-4j72-gcv7/index.md)","id":"GHSA-9w87-4j72-gcv7","markdown":"https://insights.sbomify.com/GHSA-9w87-4j72-gcv7/index.md","name":"GHSA-9w87-4j72-gcv7","record":{"aliases":[],"analysis":{"component_type":"library","fix_type":"upgrade","impacts":["security_bypass"],"network_reachable":"yes","non_default_config":false,"product_category":"GraphQL code generator","requires_auth":"none","summary":"The library disables TLS certificate verification by default, allowing attackers to intercept or manipulate network traffic via man-in-the-middle attacks.","user_interaction":"not_required","vuln_class":"misconfiguration"},"analysis_generated_by":"qwen3.8-flash-next","assigner":null,"cpe":[],"cvss":{"score":null,"severity":null,"source":null,"vector":null,"version":null},"cwes":[],"description":"Versions of `graphql-code-generator` prior to 0.18.2 have an Insecure Default Configuration. The packages sets `NODE_TLS_REJECT_UNAUTHORIZED` to 0, disabling certificate verification for the entire project. This results in Insecure Communication for the process.\n\n## Recommendation\n\nUpgrade to version 0.18.2 or later.","ecosystems":["npm"],"exploits":{"exploitdb":null,"first_seen":null,"github_poc":null,"max_poc_stars":null,"metasploit":null,"nuclei":null,"refs":[],"tier":null},"has_fix":true,"headline":"Insecure Default Configuration in graphql-code-generator","id":"GHSA-9w87-4j72-gcv7","indexable":true,"kev":null,"kind":"advisory","links":{"ecosystem":"npm","product":null,"products":[],"type":"misconfiguration","year":"2020"},"n_packages":2,"n_references":null,"packages":[{"ecosystem":"npm","fixed":["0.18.2"],"introduced":["0"],"last_affected":[],"package":"graphql-code-generator","purl":null,"source":"GHSA-9w87-4j72-gcv7"},{"ecosystem":"npm","fixed":["0.18.2"],"introduced":["0"],"last_affected":[],"package":"graphql-code-generator","purl":"pkg:npm/graphql-code-generator","source":"GHSA-9w87-4j72-gcv7"}],"products":null,"published":"2020-09-02","related":[],"sources":[{"class":"attribution","licence":"CC BY 4.0","name":"GitHub Advisory Database","prefix":"GHSA"}],"ssvc":{"automatable":null,"exploitation":null,"technical_impact":null},"state":null,"updated":null,"vendors":null},"summary":"The library disables TLS certificate verification by default, allowing attackers to intercept or manipulate network traffic via man-in-the-middle attacks.","url":"https://insights.sbomify.com/GHSA-9w87-4j72-gcv7/"}