GHSA-9wg9-93h9-j8ch Auth0 Symfony SDK Vulnerable to Brute Force Authentication Tags of CookieStore Sessions
Attackers can brute force authentication tags in CookieStore sessions to gain unauthorized access to applications using the Auth0 Symfony SDK.
- Exploited in the wild
- Not known
- Login needed
- Not needed
- Attackable
- Over the internet
- Victim action needed
- Not needed
- Fix
- Available
What is GHSA-9wg9-93h9-j8ch?
GHSA-9wg9-93h9-j8ch is an authentication bypass vulnerability in auth0/symfony, published on 17 May 2025. An attacker can exploit it over the internet without logging in, with no action from the victim.
Official description
Overview Session cookies of applications using the Auth0 symfony SDK configured with CookieStore have authentication tags that can be brute forced, which may result in unauthorized access.
Am I Affected? You are affected by this vulnerability if you meet the following pre-conditions:
- Applications using the Auth0 symfony SDK with version <=5.3.1
- Auth0/Symfony SDK uses the Auth0-PHP SDK with version 8.0.0-BETA1 or higher and below 8.14.0.
- Session storage configured with CookieStore.
Fix Upgrade Auth0/symfony to v5.4.0. As an additional precautionary measure, we recommend rotating your cookie encryption keys. Note that once updated, any previous session cookies will be rejected.
Acknowledgement Okta would like to thank Félix Charette for discovering this vulnerability.
Which versions are affected by GHSA-9wg9-93h9-j8ch?
2 open source packages ship an affected version, including auth0/symfony.
| Package | Affected | Fixed in |
|---|---|---|
auth0/symfony Packagist | All versions | 5.4.0 |
auth0/symfony Packagist | All versions | 5.4.0 |
How do I fix GHSA-9wg9-93h9-j8ch?
Upgrade auth0/symfony to 5.4.0 or later.
Upgrade, and rotate credentials and sessions that may have been exposed. More about Authentication bypass.
Is GHSA-9wg9-93h9-j8ch being exploited?
There is no known exploitation of GHSA-9wg9-93h9-j8ch in the wild and no public exploit code.