{"answers":{"affected":"2 open source packages ship an affected version, including auth0/symfony.","exploited":"There is no known exploitation of GHSA-9wg9-93h9-j8ch in the wild and no public exploit code.","fix":"Upgrade auth0/symfony to 5.4.0 or later.","what":"GHSA-9wg9-93h9-j8ch is an authentication bypass vulnerability in auth0/symfony, published on 17 May 2025. An attacker can exploit it over the internet without logging in, with no action from the victim."},"fix_prompt":"Check this codebase for GHSA-9wg9-93h9-j8ch and fix it if it is affected.\n\nWhat it is: GHSA-9wg9-93h9-j8ch is an authentication bypass vulnerability in auth0/symfony, published on 17 May 2025. An attacker can exploit it over the internet without logging in, with no action from the victim.\nExploitation: There is no known exploitation of GHSA-9wg9-93h9-j8ch in the wild and no public exploit code.\n\nAffected packages and fixed versions:\n- auth0/symfony (Packagist): affected all versions; fixed in 5.4.0\n- auth0/symfony (Packagist): affected all versions; fixed in 5.4.0\n\nTask:\n1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.\n2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.\n3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.\n4. Run the tests and summarise what changed and why.\n5. If nothing in the project is affected, say so and change nothing.\n\nReference: https://insights.sbomify.com/GHSA-9wg9-93h9-j8ch/ (Markdown: https://insights.sbomify.com/GHSA-9wg9-93h9-j8ch/index.md)","id":"GHSA-9wg9-93h9-j8ch","markdown":"https://insights.sbomify.com/GHSA-9wg9-93h9-j8ch/index.md","name":"GHSA-9wg9-93h9-j8ch","record":{"aliases":[],"analysis":{"component_type":"library","fix_type":"upgrade","impacts":["account_takeover","security_bypass"],"network_reachable":"yes","non_default_config":true,"product_category":"Auth0 Symfony SDK","requires_auth":"none","summary":"Attackers can brute force authentication tags in CookieStore sessions to gain unauthorized access to applications using the Auth0 Symfony SDK.","user_interaction":"not_required","vuln_class":"auth_bypass"},"analysis_generated_by":"qwen3.8-flash-next","assigner":null,"cpe":[],"cvss":{"score":null,"severity":null,"source":null,"vector":null,"version":null},"cwes":[],"description":"**Overview**\nSession cookies of applications using the Auth0 symfony SDK configured with CookieStore have authentication tags that can be brute forced, which may result in unauthorized access.\n\n**Am I Affected?**\nYou are affected by this vulnerability if you meet the following pre-conditions:\n1. Applications using the Auth0 symfony SDK with version \u003c=5.3.1\n2. Auth0/Symfony SDK uses the Auth0-PHP SDK with version 8.0.0-BETA1 or higher and below 8.14.0. \n3. Session storage configured with CookieStore.\n\n**Fix**\nUpgrade Auth0/symfony to v5.4.0. As an additional precautionary measure, we recommend rotating your cookie encryption keys. Note that once updated, any previous session cookies will be rejected.\n\n**Acknowledgement**\nOkta would like to thank Félix Charette for discovering this vulnerability.","ecosystems":["Packagist"],"exploits":{"exploitdb":null,"first_seen":null,"github_poc":null,"max_poc_stars":null,"metasploit":null,"nuclei":null,"refs":[],"tier":null},"has_fix":true,"headline":"Auth0 Symfony SDK Vulnerable to Brute Force Authentication Tags of CookieStore Sessions","id":"GHSA-9wg9-93h9-j8ch","indexable":true,"kev":null,"kind":"advisory","links":{"ecosystem":"Packagist","product":null,"products":[],"type":"auth_bypass","year":"2025"},"n_packages":2,"n_references":null,"packages":[{"ecosystem":"Packagist","fixed":["5.4.0"],"introduced":["0"],"last_affected":[],"package":"auth0/symfony","purl":null,"source":"GHSA-9wg9-93h9-j8ch"},{"ecosystem":"Packagist","fixed":["5.4.0"],"introduced":["0"],"last_affected":[],"package":"auth0/symfony","purl":"pkg:composer/auth0/symfony","source":"GHSA-9wg9-93h9-j8ch"}],"products":null,"published":"2025-05-17","related":[],"sources":[{"class":"attribution","licence":"CC BY 4.0","name":"GitHub Advisory Database","prefix":"GHSA"}],"ssvc":{"automatable":null,"exploitation":null,"technical_impact":null},"state":null,"updated":null,"vendors":null},"summary":"Attackers can brute force authentication tags in CookieStore sessions to gain unauthorized access to applications using the Auth0 Symfony SDK.","url":"https://insights.sbomify.com/GHSA-9wg9-93h9-j8ch/"}