GHSA-9wx7-jrvc-28mm Signature verification vulnerability in Stark Bank ecdsa libraries
Not scored
Published
Check this codebase for GHSA-9wx7-jrvc-28mm and fix it if it is affected.
What it is: GHSA-9wx7-jrvc-28mm is a vulnerability in com.starkbank:ecdsa-java, published on 8 Nov 2021. An attacker can exploit it over the internet without logging in, with no action from the victim.
Exploitation: There is no known exploitation of GHSA-9wx7-jrvc-28mm in the wild and no public exploit code.
Affected packages and fixed versions:
- com.starkbank:ecdsa-java (Maven): affected from 1.0.0; fixed in 1.0.1
- com.starkbank:ecdsa-java (Maven): affected from 1.0.0; fixed in 1.0.1
- starkbank-ecdsa (NuGet): affected from 1.3.1; fixed in 1.3.2
- starkbank-ecdsa (NuGet): affected from 1.3.1; fixed in 1.3.2
- starkbank-ecdsa (PyPI): affected all versions; fixed in 2.0.1
- starkbank-ecdsa (PyPI): affected all versions; fixed in 2.0.1
- starkbank-ecdsa (npm): affected from 1.1.2; fixed in 1.1.3
- starkbank-ecdsa (npm): affected from 1.1.2; fixed in 1.1.3
Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.
Reference: https://insights.sbomify.com/GHSA-9wx7-jrvc-28mm/ (Markdown: https://insights.sbomify.com/GHSA-9wx7-jrvc-28mm/index.md)
Attackers can forge ECDSA signatures to bypass authentication and perform unauthorized financial operations on the Stark Bank platform.
- Exploited in the wild
- Not known
- Login needed
- Not needed
- Attackable
- Over the internet
- Victim action needed
- Not needed
- Fix
- Available
What is GHSA-9wx7-jrvc-28mm?
GHSA-9wx7-jrvc-28mm is a vulnerability in com.starkbank:ecdsa-java, published on 8 Nov 2021. An attacker can exploit it over the internet without logging in, with no action from the victim.
Official description
An attacker can forge signatures on arbitrary messages that will verify for any public key. This may allow attackers to authenticate as any user within the Stark Bank platform, and bypass signature verification needed to perform operations on the platform, such as send payments and transfer funds. Additionally, the ability for attackers to forge signatures may impact other users and projects using these libraries in different and unforeseen ways.
Which versions are affected by GHSA-9wx7-jrvc-28mm?
8 open source packages ship an affected version, including com.starkbank:ecdsa-java and starkbank-ecdsa.
| Package | Affected | Fixed in |
|---|---|---|
com.starkbank:ecdsa-java Maven | From 1.0.0 | 1.0.1 |
com.starkbank:ecdsa-java Maven | From 1.0.0 | 1.0.1 |
starkbank-ecdsa NuGet | From 1.3.1 | 1.3.2 |
starkbank-ecdsa NuGet | From 1.3.1 | 1.3.2 |
starkbank-ecdsa PyPI | All versions | 2.0.1 |
starkbank-ecdsa PyPI | All versions | 2.0.1 |
2 more packages
starkbank-ecdsa npm | From 1.1.2 | 1.1.3 |
starkbank-ecdsa npm | From 1.1.2 | 1.1.3 |
How do I fix GHSA-9wx7-jrvc-28mm?
Upgrade com.starkbank:ecdsa-java to 1.0.1 or later.
Is GHSA-9wx7-jrvc-28mm being exploited?
There is no known exploitation of GHSA-9wx7-jrvc-28mm in the wild and no public exploit code.