{"answers":{"affected":"2 open source packages ship an affected version, including vant.","exploited":"There is no known exploitation of GHSA-9xr8-8hmc-389f in the wild and no public exploit code.","fix":"Upgrade vant to 2.1.8 or later.","what":"GHSA-9xr8-8hmc-389f is a cross-site scripting vulnerability in vant, published on 22 Nov 2019. An attacker can exploit it over the internet without logging in, and only if a user opens a file or follows a link."},"fix_prompt":"Check this codebase for GHSA-9xr8-8hmc-389f and fix it if it is affected.\n\nWhat it is: GHSA-9xr8-8hmc-389f is a cross-site scripting vulnerability in vant, published on 22 Nov 2019. An attacker can exploit it over the internet without logging in, and only if a user opens a file or follows a link.\nExploitation: There is no known exploitation of GHSA-9xr8-8hmc-389f in the wild and no public exploit code.\n\nAffected packages and fixed versions:\n- vant (npm): affected all versions; fixed in 2.1.8\n- vant (npm): affected all versions; fixed in 2.1.8\n\nTask:\n1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.\n2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.\n3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.\n4. Run the tests and summarise what changed and why.\n5. If nothing in the project is affected, say so and change nothing.\n\nReference: https://insights.sbomify.com/GHSA-9xr8-8hmc-389f/ (Markdown: https://insights.sbomify.com/GHSA-9xr8-8hmc-389f/index.md)","id":"GHSA-9xr8-8hmc-389f","markdown":"https://insights.sbomify.com/GHSA-9xr8-8hmc-389f/index.md","name":"GHSA-9xr8-8hmc-389f","record":{"aliases":[],"analysis":{"component_type":"library","fix_type":"upgrade","impacts":["code_execution"],"network_reachable":"yes","non_default_config":false,"product_category":"Vue UI library","requires_auth":"none","summary":"Attackers can execute arbitrary JavaScript in victims' browsers via unsanitized text in the Picker component of the vant library.","user_interaction":"required","vuln_class":"xss"},"analysis_generated_by":"qwen3.8-flash-next","assigner":null,"cpe":[],"cvss":{"score":null,"severity":null,"source":null,"vector":null,"version":null},"cwes":[],"description":"Versions of `vant` prior to 2.1.8 are vulnerable to Cross-Site Scripting. The text value of the `Picker` component column is not sanitized, which may allow attackers to execute arbitrary JavaScript in a victim's browser.\n\n## Recommendation\n\nUpgrade to version 2.1.8 or later.","ecosystems":["npm"],"exploits":{"exploitdb":null,"first_seen":null,"github_poc":null,"max_poc_stars":null,"metasploit":null,"nuclei":null,"refs":[],"tier":null},"has_fix":true,"headline":"Cross-Site Scripting in vant","id":"GHSA-9xr8-8hmc-389f","indexable":true,"kev":null,"kind":"advisory","links":{"ecosystem":"npm","product":null,"products":[],"type":"xss","year":"2019"},"n_packages":2,"n_references":null,"packages":[{"ecosystem":"npm","fixed":["2.1.8"],"introduced":["0"],"last_affected":[],"package":"vant","purl":null,"source":"GHSA-9xr8-8hmc-389f"},{"ecosystem":"npm","fixed":["2.1.8"],"introduced":["0"],"last_affected":[],"package":"vant","purl":"pkg:npm/vant","source":"GHSA-9xr8-8hmc-389f"}],"products":null,"published":"2019-11-22","related":[],"sources":[{"class":"attribution","licence":"CC BY 4.0","name":"GitHub Advisory Database","prefix":"GHSA"}],"ssvc":{"automatable":null,"exploitation":null,"technical_impact":null},"state":null,"updated":null,"vendors":null},"summary":"Attackers can execute arbitrary JavaScript in victims' browsers via unsanitized text in the Picker component of the vant library.","url":"https://insights.sbomify.com/GHSA-9xr8-8hmc-389f/"}