{"answers":{"affected":"2 open source packages ship an affected version, including helmet-csp.","exploited":"There is no known exploitation of GHSA-c3m8-x3cg-qm2c in the wild and no public exploit code.","fix":"Upgrade helmet-csp to 2.9.1 or later.","what":"GHSA-c3m8-x3cg-qm2c is a vulnerability in helmet-csp, published on 3 Sep 2020. An attacker can exploit it over the internet without logging in, and only if a user opens a file or follows a link."},"fix_prompt":"Check this codebase for GHSA-c3m8-x3cg-qm2c and fix it if it is affected.\n\nWhat it is: GHSA-c3m8-x3cg-qm2c is a vulnerability in helmet-csp, published on 3 Sep 2020. An attacker can exploit it over the internet without logging in, and only if a user opens a file or follows a link.\nExploitation: There is no known exploitation of GHSA-c3m8-x3cg-qm2c in the wild and no public exploit code.\n\nAffected packages and fixed versions:\n- helmet-csp (npm): affected from 1.2.2; fixed in 2.9.1\n- helmet-csp (npm): affected from 1.2.2; fixed in 2.9.1\n\nTask:\n1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.\n2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.\n3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.\n4. Run the tests and summarise what changed and why.\n5. If nothing in the project is affected, say so and change nothing.\n\nReference: https://insights.sbomify.com/GHSA-c3m8-x3cg-qm2c/ (Markdown: https://insights.sbomify.com/GHSA-c3m8-x3cg-qm2c/index.md)","id":"GHSA-c3m8-x3cg-qm2c","markdown":"https://insights.sbomify.com/GHSA-c3m8-x3cg-qm2c/index.md","name":"GHSA-c3m8-x3cg-qm2c","record":{"aliases":[],"analysis":{"component_type":"library","fix_type":"upgrade","impacts":["security_bypass"],"network_reachable":"yes","non_default_config":false,"product_category":"Node.js security library","requires_auth":"none","summary":"Attacker can bypass Content Security Policy protections in helmet-csp, potentially enabling Cross-Site Scripting attacks against web applications.","user_interaction":"required","vuln_class":"security_feature_bypass"},"analysis_generated_by":"qwen3.8-flash-next","assigner":null,"cpe":[],"cvss":{"score":null,"severity":null,"source":null,"vector":null,"version":null},"cwes":[],"description":"Versions of `helmet-csp` before to 2.9.1 are vulnerable to a Configuration Override affecting the application's Content Security Policy (CSP). The package's browser sniffing for Firefox deletes the `default-src` CSP policy, which is the fallback policy. This allows an attacker to remove an application's default CSP, possibly rendering the application vulnerable to Cross-Site Scripting.\n\n## Recommendation\n\nUpgrade to version 2.9.1 or later. Setting the `browserSniff` configuration to `false` in vulnerable versions also mitigates the issue.","ecosystems":["npm"],"exploits":{"exploitdb":null,"first_seen":null,"github_poc":null,"max_poc_stars":null,"metasploit":null,"nuclei":null,"refs":[],"tier":null},"has_fix":true,"headline":"Configuration Override in helmet-csp","id":"GHSA-c3m8-x3cg-qm2c","indexable":true,"kev":null,"kind":"advisory","links":{"ecosystem":"npm","product":null,"products":[],"type":"security_feature_bypass","year":"2020"},"n_packages":2,"n_references":null,"packages":[{"ecosystem":"npm","fixed":["2.9.1"],"introduced":["1.2.2"],"last_affected":[],"package":"helmet-csp","purl":null,"source":"GHSA-c3m8-x3cg-qm2c"},{"ecosystem":"npm","fixed":["2.9.1"],"introduced":["1.2.2"],"last_affected":[],"package":"helmet-csp","purl":"pkg:npm/helmet-csp","source":"GHSA-c3m8-x3cg-qm2c"}],"products":null,"published":"2020-09-03","related":[],"sources":[{"class":"attribution","licence":"CC BY 4.0","name":"GitHub Advisory Database","prefix":"GHSA"}],"ssvc":{"automatable":null,"exploitation":null,"technical_impact":null},"state":null,"updated":null,"vendors":null},"summary":"Attacker can bypass Content Security Policy protections in helmet-csp, potentially enabling Cross-Site Scripting attacks against web applications.","url":"https://insights.sbomify.com/GHSA-c3m8-x3cg-qm2c/"}