{"answers":{"affected":"2 open source packages ship an affected version, including auth0/login.","exploited":"There is no known exploitation of GHSA-c42h-56wx-h85q in the wild and no public exploit code.","fix":"Upgrade auth0/login to 7.2.2 or later.","what":"GHSA-c42h-56wx-h85q is an unsafe deserialization vulnerability in auth0/login, published on 6 Jun 2025. An attacker can exploit it over the internet without logging in, with no action from the victim."},"fix_prompt":"Check this codebase for GHSA-c42h-56wx-h85q and fix it if it is affected.\n\nWhat it is: GHSA-c42h-56wx-h85q is an unsafe deserialization vulnerability in auth0/login, published on 6 Jun 2025. An attacker can exploit it over the internet without logging in, with no action from the victim.\nExploitation: There is no known exploitation of GHSA-c42h-56wx-h85q in the wild and no public exploit code.\n\nAffected packages and fixed versions:\n- auth0/login (Packagist): affected from 7.0.0-BETA1; fixed in 7.2.2\n- auth0/login (Packagist): affected from 7.0.0-BETA1; fixed in 7.2.2\n\nTask:\n1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.\n2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.\n3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.\n4. Run the tests and summarise what changed and why.\n5. If nothing in the project is affected, say so and change nothing.\n\nReference: https://insights.sbomify.com/GHSA-c42h-56wx-h85q/ (Markdown: https://insights.sbomify.com/GHSA-c42h-56wx-h85q/index.md)","id":"GHSA-c42h-56wx-h85q","markdown":"https://insights.sbomify.com/GHSA-c42h-56wx-h85q/index.md","name":"GHSA-c42h-56wx-h85q","record":{"aliases":[],"analysis":{"component_type":"library","fix_type":"upgrade","impacts":["code_execution"],"network_reachable":"yes","non_default_config":false,"product_category":"Laravel Auth0 SDK","requires_auth":"none","summary":"Attackers can execute arbitrary code by sending malicious serialized data in cookies to applications using the vulnerable Laravel Auth0 SDK.","user_interaction":"not_required","vuln_class":"deserialization"},"analysis_generated_by":"qwen3.8-flash-next","assigner":null,"cpe":[],"cvss":{"score":null,"severity":null,"source":null,"vector":null,"version":null},"cwes":[],"description":"**Overview**\nThe laravel-auth0 SDK contains a critical vulnerability due to insecure deserialization of cookie data. If exploited, since SDKs process cookie content without prior authentication, a threat actor could send a specially crafted cookie containing malicious serialized data.\n\n**Am I Affected?**\nYou are affected by this vulnerability if you meet the following preconditions:\n\n1. Applications using laravel-auth0 SDK, versions between 7.0.0-BETA1 to 7.2.1.\n2. Laravel-auth0 SDK uses the Auth0-PHP SDK with version 8.0.0-BETA3 to 8.3.0.\n\n**Fix**\nUpgrade Auth0/laravel-auth0 to the latest version (v7.17.0).\n\n**Acknowledgement**\nOkta would like to thank Andreas Forsblom for discovering this vulnerability.","ecosystems":["Packagist"],"exploits":{"exploitdb":null,"first_seen":null,"github_poc":null,"max_poc_stars":null,"metasploit":null,"nuclei":null,"refs":[],"tier":null},"has_fix":true,"headline":"laravel-auth0 SDK Deserialization of Untrusted Data vulnerability","id":"GHSA-c42h-56wx-h85q","indexable":true,"kev":null,"kind":"advisory","links":{"ecosystem":"Packagist","product":null,"products":[],"type":"deserialization","year":"2025"},"n_packages":2,"n_references":null,"packages":[{"ecosystem":"Packagist","fixed":["7.2.2"],"introduced":["7.0.0-BETA1"],"last_affected":[],"package":"auth0/login","purl":null,"source":"GHSA-c42h-56wx-h85q"},{"ecosystem":"Packagist","fixed":["7.2.2"],"introduced":["7.0.0-BETA1"],"last_affected":[],"package":"auth0/login","purl":"pkg:composer/auth0/login","source":"GHSA-c42h-56wx-h85q"}],"products":null,"published":"2025-06-06","related":[],"sources":[{"class":"attribution","licence":"CC BY 4.0","name":"GitHub Advisory Database","prefix":"GHSA"}],"ssvc":{"automatable":null,"exploitation":null,"technical_impact":null},"state":null,"updated":null,"vendors":null},"summary":"Attackers can execute arbitrary code by sending malicious serialized data in cookies to applications using the vulnerable Laravel Auth0 SDK.","url":"https://insights.sbomify.com/GHSA-c42h-56wx-h85q/"}