# GHSA-c42h-56wx-h85q: laravel-auth0 SDK Deserialization of Untrusted Data vulnerability

> Attackers can execute arbitrary code by sending malicious serialized data in cookies to applications using the vulnerable Laravel Auth0 SDK.

- **Severity:** Not scored
- **Exploited in the wild:** Not known
- **Login needed:** Not needed
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 6 Jun 2025

## What is GHSA-c42h-56wx-h85q?

GHSA-c42h-56wx-h85q is an unsafe deserialization vulnerability in auth0/login, published on 6 Jun 2025. An attacker can exploit it over the internet without logging in, with no action from the victim.

### Official description

**Overview**
The laravel-auth0 SDK contains a critical vulnerability due to insecure deserialization of cookie data. If exploited, since SDKs process cookie content without prior authentication, a threat actor could send a specially crafted cookie containing malicious serialized data.

**Am I Affected?**
You are affected by this vulnerability if you meet the following preconditions:

1. Applications using laravel-auth0 SDK, versions between 7.0.0-BETA1 to 7.2.1.
2. Laravel-auth0 SDK uses the Auth0-PHP SDK with version 8.0.0-BETA3 to 8.3.0.

**Fix**
Upgrade Auth0/laravel-auth0 to the latest version (v7.17.0).

**Acknowledgement**
Okta would like to thank Andreas Forsblom for discovering this vulnerability.

## Which versions are affected by GHSA-c42h-56wx-h85q?

2 open source packages ship an affected version, including auth0/login.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `auth0/login` | Packagist | From 7.0.0-BETA1 | 7.2.2 |
| `auth0/login` | Packagist | From 7.0.0-BETA1 | 7.2.2 |

## How do I fix GHSA-c42h-56wx-h85q?

Upgrade auth0/login to 7.2.2 or later.

## Is GHSA-c42h-56wx-h85q being exploited?

There is no known exploitation of GHSA-c42h-56wx-h85q in the wild and no public exploit code.

## Fix prompt for AI coding agents

```text
Check this codebase for GHSA-c42h-56wx-h85q and fix it if it is affected.

What it is: GHSA-c42h-56wx-h85q is an unsafe deserialization vulnerability in auth0/login, published on 6 Jun 2025. An attacker can exploit it over the internet without logging in, with no action from the victim.
Exploitation: There is no known exploitation of GHSA-c42h-56wx-h85q in the wild and no public exploit code.

Affected packages and fixed versions:
- auth0/login (Packagist): affected from 7.0.0-BETA1; fixed in 7.2.2
- auth0/login (Packagist): affected from 7.0.0-BETA1; fixed in 7.2.2

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/GHSA-c42h-56wx-h85q/ (Markdown: https://insights.sbomify.com/GHSA-c42h-56wx-h85q/index.md)
```

## Sources

- OSV: https://osv.dev/vulnerability/GHSA-c42h-56wx-h85q

---
From sbomify Insights: https://insights.sbomify.com/GHSA-c42h-56wx-h85q/
Summaries are generated and may contain mistakes; the official description above is the record.
