GHSA-c57f-4vp2-jqhm Insecure temporary directory usage in frontend build functionality of Vaadin 14 and 15-19
Local attackers can inject malicious code into frontend resources during application rebuilds due to insecure temporary directory usage in Vaadin.
- Exploited in the wild
- Not known
- Login needed
- Any signed-in user
- Attackable
- Local or same network only
- Victim action needed
- Not needed
- Fix
- Available
What is GHSA-c57f-4vp2-jqhm?
GHSA-c57f-4vp2-jqhm is a path traversal vulnerability in com.vaadin:flow-server, published on 6 May 2021. It can only be exploited from the same machine or local network, with no action from the victim.
Official description
Insecure temporary directory usage in frontend build functionality of com.vaadin:flow-server versions 2.0.9 through 2.5.2 (Vaadin 14.0.3 through Vaadin 14.5.2), 3.0 prior to 6.0 (Vaadin 15 prior to 19), and 6.0.0 through 6.0.5 (Vaadin 19.0.0 through 19.0.4) allows local users to inject malicious code into frontend resources during application rebuilds.
Which versions are affected by GHSA-c57f-4vp2-jqhm?
4 open source packages ship an affected version, including com.vaadin:flow-server.
| Package | Affected | Fixed in |
|---|---|---|
com.vaadin:flow-server Maven | From 2.0.9 | 2.5.3 |
com.vaadin:flow-server Maven | From 2.0.9 | 2.5.3 |
com.vaadin:flow-server Maven | From 3.0.0 | 6.0.6 |
com.vaadin:flow-server Maven | From 3.0.0 | 6.0.6 |
How do I fix GHSA-c57f-4vp2-jqhm?
Upgrade com.vaadin:flow-server to a fixed version for your release line: 2.5.3 or 6.0.6.
Upgrade, and resolve every user-supplied path against an allowed base folder before opening it. More about Path traversal.
Is GHSA-c57f-4vp2-jqhm being exploited?
There is no known exploitation of GHSA-c57f-4vp2-jqhm in the wild and no public exploit code.