{"answers":{"affected":"4 open source packages ship an affected version, including com.vaadin:flow-server.","exploited":"There is no known exploitation of GHSA-c57f-4vp2-jqhm in the wild and no public exploit code.","fix":"Upgrade com.vaadin:flow-server to a fixed version for your release line: 2.5.3 or 6.0.6.","what":"GHSA-c57f-4vp2-jqhm is a path traversal vulnerability in com.vaadin:flow-server, published on 6 May 2021. It can only be exploited from the same machine or local network, with no action from the victim."},"fix_prompt":"Check this codebase for GHSA-c57f-4vp2-jqhm and fix it if it is affected.\n\nWhat it is: GHSA-c57f-4vp2-jqhm is a path traversal vulnerability in com.vaadin:flow-server, published on 6 May 2021. It can only be exploited from the same machine or local network, with no action from the victim.\nExploitation: There is no known exploitation of GHSA-c57f-4vp2-jqhm in the wild and no public exploit code.\n\nAffected packages and fixed versions:\n- com.vaadin:flow-server (Maven): affected from 2.0.9; fixed in 2.5.3\n- com.vaadin:flow-server (Maven): affected from 2.0.9; fixed in 2.5.3\n- com.vaadin:flow-server (Maven): affected from 3.0.0; fixed in 6.0.6\n- com.vaadin:flow-server (Maven): affected from 3.0.0; fixed in 6.0.6\n\nTask:\n1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.\n2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.\n3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.\n4. Run the tests and summarise what changed and why.\n5. If nothing in the project is affected, say so and change nothing.\n\nReference: https://insights.sbomify.com/GHSA-c57f-4vp2-jqhm/ (Markdown: https://insights.sbomify.com/GHSA-c57f-4vp2-jqhm/index.md)","id":"GHSA-c57f-4vp2-jqhm","markdown":"https://insights.sbomify.com/GHSA-c57f-4vp2-jqhm/index.md","name":"GHSA-c57f-4vp2-jqhm","record":{"aliases":[],"analysis":{"component_type":"library","fix_type":"upgrade","impacts":["code_execution"],"network_reachable":"adjacent_or_local","non_default_config":false,"product_category":"Vaadin Java library","requires_auth":"low_privilege","summary":"Local attackers can inject malicious code into frontend resources during application rebuilds due to insecure temporary directory usage in Vaadin.","user_interaction":"not_required","vuln_class":"path_traversal"},"analysis_generated_by":"qwen3.8-flash-next","assigner":null,"cpe":[],"cvss":{"score":null,"severity":null,"source":null,"vector":null,"version":null},"cwes":[],"description":"Insecure temporary directory usage in frontend build functionality of `com.vaadin:flow-server` versions 2.0.9 through 2.5.2 (Vaadin 14.0.3 through Vaadin 14.5.2), 3.0 prior to 6.0 (Vaadin 15 prior to 19), and 6.0.0 through 6.0.5 (Vaadin 19.0.0 through 19.0.4) allows local users to inject malicious code into frontend resources during application rebuilds.\n\n- https://vaadin.com/security/cve-2021-31411","ecosystems":["Maven"],"exploits":{"exploitdb":null,"first_seen":null,"github_poc":null,"max_poc_stars":null,"metasploit":null,"nuclei":null,"refs":[],"tier":null},"has_fix":true,"headline":"Insecure temporary directory usage in frontend build functionality of Vaadin 14 and 15-19","id":"GHSA-c57f-4vp2-jqhm","indexable":true,"kev":null,"kind":"advisory","links":{"ecosystem":"Maven","product":null,"products":[],"type":"path_traversal","year":"2021"},"n_packages":4,"n_references":null,"packages":[{"ecosystem":"Maven","fixed":["2.5.3"],"introduced":["2.0.9"],"last_affected":[],"package":"com.vaadin:flow-server","purl":null,"source":"GHSA-c57f-4vp2-jqhm"},{"ecosystem":"Maven","fixed":["2.5.3"],"introduced":["2.0.9"],"last_affected":[],"package":"com.vaadin:flow-server","purl":"pkg:maven/com.vaadin/flow-server","source":"GHSA-c57f-4vp2-jqhm"},{"ecosystem":"Maven","fixed":["6.0.6"],"introduced":["3.0.0"],"last_affected":[],"package":"com.vaadin:flow-server","purl":null,"source":"GHSA-c57f-4vp2-jqhm"},{"ecosystem":"Maven","fixed":["6.0.6"],"introduced":["3.0.0"],"last_affected":[],"package":"com.vaadin:flow-server","purl":"pkg:maven/com.vaadin/flow-server","source":"GHSA-c57f-4vp2-jqhm"}],"products":null,"published":"2021-05-06","related":[],"sources":[{"class":"attribution","licence":"CC BY 4.0","name":"GitHub Advisory Database","prefix":"GHSA"}],"ssvc":{"automatable":null,"exploitation":null,"technical_impact":null},"state":null,"updated":null,"vendors":null},"summary":"Local attackers can inject malicious code into frontend resources during application rebuilds due to insecure temporary directory usage in Vaadin.","url":"https://insights.sbomify.com/GHSA-c57f-4vp2-jqhm/"}