{"answers":{"affected":"2 open source packages ship an affected version, including pycares.","exploited":"There is no known exploitation of GHSA-c58j-88f5-h53f in the wild and no public exploit code.","fix":"Upgrade pycares to 4.2.0 or later.","what":"GHSA-c58j-88f5-h53f is a cross-site scripting vulnerability in pycares, published on 5 Jul 2022. It can be exploited over the network, and only if a user opens a file or follows a link."},"fix_prompt":"Check this codebase for GHSA-c58j-88f5-h53f and fix it if it is affected.\n\nWhat it is: GHSA-c58j-88f5-h53f is a cross-site scripting vulnerability in pycares, published on 5 Jul 2022. It can be exploited over the network, and only if a user opens a file or follows a link.\nExploitation: There is no known exploitation of GHSA-c58j-88f5-h53f in the wild and no public exploit code.\n\nAffected packages and fixed versions:\n- pycares (PyPI): affected all versions; fixed in 4.2.0\n- pycares (PyPI): affected all versions; fixed in 4.2.0\n\nTask:\n1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.\n2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.\n3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.\n4. Run the tests and summarise what changed and why.\n5. If nothing in the project is affected, say so and change nothing.\n\nReference: https://insights.sbomify.com/GHSA-c58j-88f5-h53f/ (Markdown: https://insights.sbomify.com/GHSA-c58j-88f5-h53f/index.md)","id":"GHSA-c58j-88f5-h53f","markdown":"https://insights.sbomify.com/GHSA-c58j-88f5-h53f/index.md","name":"GHSA-c58j-88f5-h53f","record":{"aliases":[],"analysis":{"component_type":"library","fix_type":"upgrade","impacts":["code_execution"],"network_reachable":"yes","non_default_config":false,"product_category":"Python DNS library","requires_auth":"unknown","summary":"Cross-site scripting vulnerability in pycares allows attackers to inject malicious scripts into web pages viewed by other users.","user_interaction":"required","vuln_class":"xss"},"analysis_generated_by":"qwen3.8-flash-next","assigner":null,"cpe":[],"cvss":{"score":null,"severity":null,"source":null,"vector":null,"version":null},"cwes":[],"description":"### Impact\n\npycares versions \u003c 4.2.0 are affected by [CVE-2021-3672](https://nvd.nist.gov/vuln/detail/CVE-2021-3672).\n\n### Patches\n\nUpdate to version 4.2.0.","ecosystems":["PyPI"],"exploits":{"exploitdb":null,"first_seen":null,"github_poc":null,"max_poc_stars":null,"metasploit":null,"nuclei":null,"refs":[],"tier":null},"has_fix":true,"headline":"Improper Neutralization of Input During Web Page Generation ('Cross-site Scripting') in pycares","id":"GHSA-c58j-88f5-h53f","indexable":true,"kev":null,"kind":"advisory","links":{"ecosystem":"PyPI","product":null,"products":[],"type":"xss","year":"2022"},"n_packages":2,"n_references":null,"packages":[{"ecosystem":"PyPI","fixed":["4.2.0"],"introduced":["0"],"last_affected":[],"package":"pycares","purl":null,"source":"GHSA-c58j-88f5-h53f"},{"ecosystem":"PyPI","fixed":["4.2.0"],"introduced":["0"],"last_affected":[],"package":"pycares","purl":"pkg:pypi/pycares","source":"GHSA-c58j-88f5-h53f"}],"products":null,"published":"2022-07-05","related":[],"sources":[{"class":"attribution","licence":"CC BY 4.0","name":"GitHub Advisory Database","prefix":"GHSA"}],"ssvc":{"automatable":null,"exploitation":null,"technical_impact":null},"state":null,"updated":null,"vendors":null},"summary":"Cross-site scripting vulnerability in pycares allows attackers to inject malicious scripts into web pages viewed by other users.","url":"https://insights.sbomify.com/GHSA-c58j-88f5-h53f/"}