{"answers":{"affected":"2 open source packages ship an affected version, including bootstrap-vue.","exploited":"There is no known exploitation of GHSA-c7pp-x73h-4m2v in the wild and no public exploit code.","fix":"Upgrade bootstrap-vue to 2.0.0-rc.12 or later.","what":"GHSA-c7pp-x73h-4m2v is a cross-site scripting vulnerability in bootstrap-vue, published on 2 Sep 2020. An attacker can exploit it over the internet without logging in, and only if a user opens a file or follows a link."},"fix_prompt":"Check this codebase for GHSA-c7pp-x73h-4m2v and fix it if it is affected.\n\nWhat it is: GHSA-c7pp-x73h-4m2v is a cross-site scripting vulnerability in bootstrap-vue, published on 2 Sep 2020. An attacker can exploit it over the internet without logging in, and only if a user opens a file or follows a link.\nExploitation: There is no known exploitation of GHSA-c7pp-x73h-4m2v in the wild and no public exploit code.\n\nAffected packages and fixed versions:\n- bootstrap-vue (npm): affected all versions; fixed in 2.0.0-rc.12\n- bootstrap-vue (npm): affected all versions; fixed in 2.0.0-rc.12\n\nTask:\n1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.\n2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.\n3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.\n4. Run the tests and summarise what changed and why.\n5. If nothing in the project is affected, say so and change nothing.\n\nReference: https://insights.sbomify.com/GHSA-c7pp-x73h-4m2v/ (Markdown: https://insights.sbomify.com/GHSA-c7pp-x73h-4m2v/index.md)","id":"GHSA-c7pp-x73h-4m2v","markdown":"https://insights.sbomify.com/GHSA-c7pp-x73h-4m2v/index.md","name":"GHSA-c7pp-x73h-4m2v","record":{"aliases":[],"analysis":{"component_type":"library","fix_type":"upgrade","impacts":["code_execution"],"network_reachable":"yes","non_default_config":false,"product_category":"Vue UI library","requires_auth":"none","summary":"Insufficient input sanitization in bootstrap-vue allows attackers to execute malicious JavaScript in users' browsers via the options variable.","user_interaction":"required","vuln_class":"xss"},"analysis_generated_by":"qwen3.8-flash-next","assigner":null,"cpe":[],"cvss":{"score":null,"severity":null,"source":null,"vector":null,"version":null},"cwes":[],"description":"Versions of `bootstrap-vue` prior to 2.0.0-rc.12 are vulnerable to Cross-Site Scripting. Due to insufficient input sanitization, components may be vulnerable to Cross-Site Scripting through the `options` variable. This may lead to the execution of malicious JavaScript on the user's browser.\n\n## Recommendation\n\nUpgrade to version 2.0.0-rc.12 or later.","ecosystems":["npm"],"exploits":{"exploitdb":null,"first_seen":null,"github_poc":null,"max_poc_stars":null,"metasploit":null,"nuclei":null,"refs":[],"tier":null},"has_fix":true,"headline":"Cross-Site Scripting in bootstrap-vue","id":"GHSA-c7pp-x73h-4m2v","indexable":true,"kev":null,"kind":"advisory","links":{"ecosystem":"npm","product":null,"products":[],"type":"xss","year":"2020"},"n_packages":2,"n_references":null,"packages":[{"ecosystem":"npm","fixed":["2.0.0-rc.12"],"introduced":["0"],"last_affected":[],"package":"bootstrap-vue","purl":null,"source":"GHSA-c7pp-x73h-4m2v"},{"ecosystem":"npm","fixed":["2.0.0-rc.12"],"introduced":["0"],"last_affected":[],"package":"bootstrap-vue","purl":"pkg:npm/bootstrap-vue","source":"GHSA-c7pp-x73h-4m2v"}],"products":null,"published":"2020-09-02","related":[],"sources":[{"class":"attribution","licence":"CC BY 4.0","name":"GitHub Advisory Database","prefix":"GHSA"}],"ssvc":{"automatable":null,"exploitation":null,"technical_impact":null},"state":null,"updated":null,"vendors":null},"summary":"Insufficient input sanitization in bootstrap-vue allows attackers to execute malicious JavaScript in users' browsers via the options variable.","url":"https://insights.sbomify.com/GHSA-c7pp-x73h-4m2v/"}