{"answers":{"affected":"2 open source packages ship an affected version, including markdown-to-jsx.","exploited":"There is no known exploitation of GHSA-ccrp-c664-8p4j in the wild and no public exploit code.","fix":"Upgrade markdown-to-jsx to 6.11.4 or later.","what":"GHSA-ccrp-c664-8p4j is a cross-site scripting vulnerability in markdown-to-jsx, published on 3 Sep 2020. An attacker can exploit it over the internet without logging in, and only if a user opens a file or follows a link."},"fix_prompt":"Check this codebase for GHSA-ccrp-c664-8p4j and fix it if it is affected.\n\nWhat it is: GHSA-ccrp-c664-8p4j is a cross-site scripting vulnerability in markdown-to-jsx, published on 3 Sep 2020. An attacker can exploit it over the internet without logging in, and only if a user opens a file or follows a link.\nExploitation: There is no known exploitation of GHSA-ccrp-c664-8p4j in the wild and no public exploit code.\n\nAffected packages and fixed versions:\n- markdown-to-jsx (npm): affected all versions; fixed in 6.11.4\n- markdown-to-jsx (npm): affected all versions; fixed in 6.11.4\n\nTask:\n1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.\n2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.\n3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.\n4. Run the tests and summarise what changed and why.\n5. If nothing in the project is affected, say so and change nothing.\n\nReference: https://insights.sbomify.com/GHSA-ccrp-c664-8p4j/ (Markdown: https://insights.sbomify.com/GHSA-ccrp-c664-8p4j/index.md)","id":"GHSA-ccrp-c664-8p4j","markdown":"https://insights.sbomify.com/GHSA-ccrp-c664-8p4j/index.md","name":"GHSA-ccrp-c664-8p4j","record":{"aliases":[],"analysis":{"component_type":"library","fix_type":"upgrade","impacts":["code_execution"],"network_reachable":"yes","non_default_config":false,"product_category":"JavaScript markdown library","requires_auth":"none","summary":"Attackers can execute malicious JavaScript in user browsers via crafted markdown links, requiring an upgrade to the markdown-to-jsx library.","user_interaction":"required","vuln_class":"xss"},"analysis_generated_by":"qwen3.8-flash-next","assigner":null,"cpe":[],"cvss":{"score":null,"severity":null,"source":null,"vector":null,"version":null},"cwes":[],"description":"Versions of `markdown-to-jsx` prior to 6.11.4 are vulnerable to Cross-Site Scripting. Due to insufficient input sanitization the package may render output containing malicious JavaScript. This vulnerability can be exploited through input of links containing `data` or VBScript URIs and a base64-encoded payload.\n\n## Recommendation\n\nUpgrade to version 6.11.4 or later.","ecosystems":["npm"],"exploits":{"exploitdb":null,"first_seen":null,"github_poc":null,"max_poc_stars":null,"metasploit":null,"nuclei":null,"refs":[],"tier":null},"has_fix":true,"headline":"Cross-Site Scripting in markdown-to-jsx","id":"GHSA-ccrp-c664-8p4j","indexable":true,"kev":null,"kind":"advisory","links":{"ecosystem":"npm","product":null,"products":[],"type":"xss","year":"2020"},"n_packages":2,"n_references":null,"packages":[{"ecosystem":"npm","fixed":["6.11.4"],"introduced":["0"],"last_affected":[],"package":"markdown-to-jsx","purl":null,"source":"GHSA-ccrp-c664-8p4j"},{"ecosystem":"npm","fixed":["6.11.4"],"introduced":["0"],"last_affected":[],"package":"markdown-to-jsx","purl":"pkg:npm/markdown-to-jsx","source":"GHSA-ccrp-c664-8p4j"}],"products":null,"published":"2020-09-03","related":[],"sources":[{"class":"attribution","licence":"CC BY 4.0","name":"GitHub Advisory Database","prefix":"GHSA"}],"ssvc":{"automatable":null,"exploitation":null,"technical_impact":null},"state":null,"updated":null,"vendors":null},"summary":"Attackers can execute malicious JavaScript in user browsers via crafted markdown links, requiring an upgrade to the markdown-to-jsx library.","url":"https://insights.sbomify.com/GHSA-ccrp-c664-8p4j/"}