{"answers":{"affected":"3 open source packages ship an affected version, including pnet_packet.","exploited":"There is no known exploitation of GHSA-cf4g-fcf8-3cr9 in the wild and no public exploit code.","fix":"Upgrade pnet_packet to 0.27.2 or later.","what":"GHSA-cf4g-fcf8-3cr9 is a memory corruption vulnerability in pnet_packet, published on 19 Jun 2020. An attacker can exploit it over the internet without logging in, with no action from the victim."},"fix_prompt":"Check this codebase for GHSA-cf4g-fcf8-3cr9 and fix it if it is affected.\n\nWhat it is: GHSA-cf4g-fcf8-3cr9 is a memory corruption vulnerability in pnet_packet, published on 19 Jun 2020. An attacker can exploit it over the internet without logging in, with no action from the victim.\nExploitation: There is no known exploitation of GHSA-cf4g-fcf8-3cr9 in the wild and no public exploit code.\n\nAffected packages and fixed versions:\n- pnet_packet (crates.io): affected all versions; fixed in 0.27.2\n- pnet_packet (crates.io): affected all versions; fixed in 0.27.2\n- pnet_packet (crates.io): affected from 0.0.0-0; fixed in 0.27.2\n\nTask:\n1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.\n2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.\n3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.\n4. Run the tests and summarise what changed and why.\n5. If nothing in the project is affected, say so and change nothing.\n\nReference: https://insights.sbomify.com/GHSA-cf4g-fcf8-3cr9/ (Markdown: https://insights.sbomify.com/GHSA-cf4g-fcf8-3cr9/index.md)","id":"GHSA-cf4g-fcf8-3cr9","markdown":"https://insights.sbomify.com/GHSA-cf4g-fcf8-3cr9/index.md","name":"GHSA-cf4g-fcf8-3cr9","record":{"aliases":["RUSTSEC-2020-0167"],"analysis":{"component_type":"library","fix_type":"upgrade","impacts":["code_execution","denial_of_service"],"network_reachable":"yes","non_default_config":false,"product_category":"Rust networking library","requires_auth":"none","summary":"A buffer overrun in the pnet_packet library allows attackers to cause memory corruption, potentially leading to code execution or denial of service.","user_interaction":"not_required","vuln_class":"memory_corruption"},"analysis_generated_by":"qwen3.8-flash-next","assigner":null,"cpe":[],"cvss":{"score":null,"severity":null,"source":null,"vector":null,"version":null},"cwes":[],"description":"As indicated by this [issue](https://github.com/libpnet/libpnet/issues/449#issuecomment-663355987), a buffer overrun is possible in the `set_payload` setter of the various mutable \"Packet\" struct setters. The offending `set_payload` functions were defined within the struct `impl` blocks in earlier versions of the package, and later by the `packet` macro.\n\nFixed in the `packet` macro by [this](https://github.com/libpnet/libpnet/pull/455) PR.","ecosystems":["crates.io"],"exploits":{"exploitdb":null,"first_seen":null,"github_poc":null,"max_poc_stars":null,"metasploit":null,"nuclei":null,"refs":[],"tier":null},"has_fix":true,"headline":"`pnet_packet` buffer overrun in `set_payload` setters","id":"GHSA-cf4g-fcf8-3cr9","indexable":true,"kev":null,"kind":"advisory","links":{"ecosystem":"crates.io","product":null,"products":[],"type":"memory_corruption","year":"2020"},"n_packages":3,"n_references":null,"packages":[{"ecosystem":"crates.io","fixed":["0.27.2"],"introduced":["0"],"last_affected":[],"package":"pnet_packet","purl":null,"source":"GHSA-cf4g-fcf8-3cr9"},{"ecosystem":"crates.io","fixed":["0.27.2"],"introduced":["0"],"last_affected":[],"package":"pnet_packet","purl":"pkg:cargo/pnet_packet","source":"GHSA-cf4g-fcf8-3cr9"},{"ecosystem":"crates.io","fixed":["0.27.2"],"introduced":["0.0.0-0"],"last_affected":[],"package":"pnet_packet","purl":"pkg:cargo/pnet_packet","source":"RUSTSEC-2020-0167"}],"products":null,"published":"2020-06-19","related":[],"sources":[{"class":"attribution","licence":"CC BY 4.0","name":"GitHub Advisory Database","prefix":"GHSA"},{"class":"open","licence":"CC0 1.0","name":"RustSec","prefix":"RUSTSEC"}],"ssvc":{"automatable":null,"exploitation":null,"technical_impact":null},"state":null,"updated":null,"vendors":null},"summary":"A buffer overrun in the pnet_packet library allows attackers to cause memory corruption, potentially leading to code execution or denial of service.","url":"https://insights.sbomify.com/GHSA-cf4g-fcf8-3cr9/"}