{"answers":{"affected":"2 open source packages ship an affected version, including pimcore/pimcore.","exploited":"There is no known exploitation of GHSA-cfcv-q4qq-2ph4 in the wild and no public exploit code.","fix":"Upgrade pimcore/pimcore to 10.1.1 or later.","what":"GHSA-cfcv-q4qq-2ph4 is a cross-site scripting vulnerability in pimcore/pimcore, published on 23 Aug 2021. Any signed-in user can exploit it over the network, and only if a user opens a file or follows a link."},"fix_prompt":"Check this codebase for GHSA-cfcv-q4qq-2ph4 and fix it if it is affected.\n\nWhat it is: GHSA-cfcv-q4qq-2ph4 is a cross-site scripting vulnerability in pimcore/pimcore, published on 23 Aug 2021. Any signed-in user can exploit it over the network, and only if a user opens a file or follows a link.\nExploitation: There is no known exploitation of GHSA-cfcv-q4qq-2ph4 in the wild and no public exploit code.\n\nAffected packages and fixed versions:\n- pimcore/pimcore (Packagist): affected all versions; fixed in 10.1.1\n- pimcore/pimcore (Packagist): affected all versions; fixed in 10.1.1\n\nTask:\n1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.\n2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.\n3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.\n4. Run the tests and summarise what changed and why.\n5. If nothing in the project is affected, say so and change nothing.\n\nReference: https://insights.sbomify.com/GHSA-cfcv-q4qq-2ph4/ (Markdown: https://insights.sbomify.com/GHSA-cfcv-q4qq-2ph4/index.md)","id":"GHSA-cfcv-q4qq-2ph4","markdown":"https://insights.sbomify.com/GHSA-cfcv-q4qq-2ph4/index.md","name":"GHSA-cfcv-q4qq-2ph4","record":{"aliases":[],"analysis":{"component_type":"library","fix_type":"upgrade","impacts":["code_execution","data_read"],"network_reachable":"yes","non_default_config":false,"product_category":"CKEditor 4","requires_auth":"low_privilege","summary":"Cross-site scripting vulnerabilities in CKEditor 4 allow attackers to execute arbitrary scripts in the context of other users.","user_interaction":"required","vuln_class":"xss"},"analysis_generated_by":"qwen3.8-flash-next","assigner":null,"cpe":[],"cvss":{"score":null,"severity":null,"source":null,"vector":null,"version":null},"cwes":[],"description":"Details see: \n\nhttps://github.com/ckeditor/ckeditor4/security/advisories/GHSA-m94c-37g6-cjhc ( CVE-2021-37695 )\nhttps://github.com/ckeditor/ckeditor4/security/advisories/GHSA-6226-h7ff-ch6c ( CVE-2021-32808 )\nhttps://github.com/ckeditor/ckeditor4/security/advisories/GHSA-7889-rm5j-hpgg  ( CVE-2021-32809 )\n\nPatch: \nhttps://github.com/pimcore/pimcore/pull/10032","ecosystems":["Packagist"],"exploits":{"exploitdb":null,"first_seen":null,"github_poc":null,"max_poc_stars":null,"metasploit":null,"nuclei":null,"refs":[],"tier":null},"has_fix":true,"headline":"CKEditor 4 vulnerabilities in versions \u003c4.16.1","id":"GHSA-cfcv-q4qq-2ph4","indexable":true,"kev":null,"kind":"advisory","links":{"ecosystem":"Packagist","product":null,"products":[],"type":"xss","year":"2021"},"n_packages":2,"n_references":null,"packages":[{"ecosystem":"Packagist","fixed":["10.1.1"],"introduced":["0"],"last_affected":[],"package":"pimcore/pimcore","purl":null,"source":"GHSA-cfcv-q4qq-2ph4"},{"ecosystem":"Packagist","fixed":["10.1.1"],"introduced":["0"],"last_affected":[],"package":"pimcore/pimcore","purl":"pkg:composer/pimcore/pimcore","source":"GHSA-cfcv-q4qq-2ph4"}],"products":null,"published":"2021-08-23","related":[],"sources":[{"class":"attribution","licence":"CC BY 4.0","name":"GitHub Advisory Database","prefix":"GHSA"}],"ssvc":{"automatable":null,"exploitation":null,"technical_impact":null},"state":null,"updated":null,"vendors":null},"summary":"Cross-site scripting vulnerabilities in CKEditor 4 allow attackers to execute arbitrary scripts in the context of other users.","url":"https://insights.sbomify.com/GHSA-cfcv-q4qq-2ph4/"}