{"answers":{"affected":"2 open source packages ship an affected version, including @spscommerce/ds-react.","exploited":"There is no known exploitation of GHSA-cfxh-frx4-9gjg in the wild and no public exploit code.","fix":"Upgrade @spscommerce/ds-react to 7.17.4 or later.","what":"GHSA-cfxh-frx4-9gjg is a cross-site scripting vulnerability in @spscommerce/ds-react, published on 15 Dec 2023. An attacker can exploit it over the internet without logging in, and only if a user opens a file or follows a link."},"fix_prompt":"Check this codebase for GHSA-cfxh-frx4-9gjg and fix it if it is affected.\n\nWhat it is: GHSA-cfxh-frx4-9gjg is a cross-site scripting vulnerability in @spscommerce/ds-react, published on 15 Dec 2023. An attacker can exploit it over the internet without logging in, and only if a user opens a file or follows a link.\nExploitation: There is no known exploitation of GHSA-cfxh-frx4-9gjg in the wild and no public exploit code.\n\nAffected packages and fixed versions:\n- @spscommerce/ds-react (npm): affected from 4.12.2; fixed in 7.17.4\n- @spscommerce/ds-react (npm): affected from 4.12.2; fixed in 7.17.4\n\nTask:\n1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.\n2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.\n3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.\n4. Run the tests and summarise what changed and why.\n5. If nothing in the project is affected, say so and change nothing.\n\nReference: https://insights.sbomify.com/GHSA-cfxh-frx4-9gjg/ (Markdown: https://insights.sbomify.com/GHSA-cfxh-frx4-9gjg/index.md)","id":"GHSA-cfxh-frx4-9gjg","markdown":"https://insights.sbomify.com/GHSA-cfxh-frx4-9gjg/index.md","name":"GHSA-cfxh-frx4-9gjg","record":{"aliases":[],"analysis":{"component_type":"library","fix_type":"upgrade","impacts":["code_execution","data_read"],"network_reachable":"yes","non_default_config":false,"product_category":"React UI library","requires_auth":"none","summary":"Cross-site scripting vulnerability in SPS Commerce React UI library allows attackers to execute scripts via user-controlled options.","user_interaction":"required","vuln_class":"xss"},"analysis_generated_by":"qwen3.8-flash-next","assigner":null,"cpe":[],"cvss":{"score":null,"severity":null,"source":null,"vector":null,"version":null},"cwes":[],"description":"### Impact\nXSS, anyone using the SPS Select with options prop populated from user input is impacted. If these options are stored, then it could have been a stored XSS. \n\n### Patches\nThe code has been patched for version 7 of woodland. Users should upgrade to 7.17.4 or higher\n\n### Workarounds\nThis is not recommended. If you are not upgrading then you would need to sanitize your options yourself (including those currently stored in databases). This is not recommended.\n\n### References\nhttps://github.com/SPSCommerce/woodland/blob/c49e999f97f3c0b56502859f4de1e8c6666dd74d/packages/ds-react/src/option-list/SpsOptionList.tsx#L559","ecosystems":["npm"],"exploits":{"exploitdb":null,"first_seen":null,"github_poc":null,"max_poc_stars":null,"metasploit":null,"nuclei":null,"refs":[],"tier":null},"has_fix":true,"headline":"Cross-site Scripting in @spscommerce/ds-react","id":"GHSA-cfxh-frx4-9gjg","indexable":true,"kev":null,"kind":"advisory","links":{"ecosystem":"npm","product":null,"products":[],"type":"xss","year":"2023"},"n_packages":2,"n_references":null,"packages":[{"ecosystem":"npm","fixed":["7.17.4"],"introduced":["4.12.2"],"last_affected":[],"package":"@spscommerce/ds-react","purl":null,"source":"GHSA-cfxh-frx4-9gjg"},{"ecosystem":"npm","fixed":["7.17.4"],"introduced":["4.12.2"],"last_affected":[],"package":"@spscommerce/ds-react","purl":"pkg:npm/%40spscommerce/ds-react","source":"GHSA-cfxh-frx4-9gjg"}],"products":null,"published":"2023-12-15","related":[],"sources":[{"class":"attribution","licence":"CC BY 4.0","name":"GitHub Advisory Database","prefix":"GHSA"}],"ssvc":{"automatable":null,"exploitation":null,"technical_impact":null},"state":null,"updated":null,"vendors":null},"summary":"Cross-site scripting vulnerability in SPS Commerce React UI library allows attackers to execute scripts via user-controlled options.","url":"https://insights.sbomify.com/GHSA-cfxh-frx4-9gjg/"}