{"answers":{"affected":"2 open source packages ship an affected version, including zendframework/zend-http.","exploited":"There is no known exploitation of GHSA-cg8w-5jrc-675g in the wild and no public exploit code.","fix":"Upgrade zendframework/zend-http to 2.8.1 or later.","what":"GHSA-cg8w-5jrc-675g is a server-side request forgery vulnerability in zendframework/zend-http, published on 7 Jun 2024. An attacker can exploit it over the internet without logging in, with no action from the victim."},"fix_prompt":"Check this codebase for GHSA-cg8w-5jrc-675g and fix it if it is affected.\n\nWhat it is: GHSA-cg8w-5jrc-675g is a server-side request forgery vulnerability in zendframework/zend-http, published on 7 Jun 2024. An attacker can exploit it over the internet without logging in, with no action from the victim.\nExploitation: There is no known exploitation of GHSA-cg8w-5jrc-675g in the wild and no public exploit code.\n\nAffected packages and fixed versions:\n- zendframework/zend-http (Packagist): affected from 1.0.0; fixed in 2.8.1\n- zendframework/zend-http (Packagist): affected from 1.0.0; fixed in 2.8.1\n\nTask:\n1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.\n2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.\n3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.\n4. Run the tests and summarise what changed and why.\n5. If nothing in the project is affected, say so and change nothing.\n\nReference: https://insights.sbomify.com/GHSA-cg8w-5jrc-675g/ (Markdown: https://insights.sbomify.com/GHSA-cg8w-5jrc-675g/index.md)","id":"GHSA-cg8w-5jrc-675g","markdown":"https://insights.sbomify.com/GHSA-cg8w-5jrc-675g/index.md","name":"GHSA-cg8w-5jrc-675g","record":{"aliases":[],"analysis":{"component_type":"library","fix_type":"upgrade","impacts":["data_read","security_bypass"],"network_reachable":"yes","non_default_config":false,"product_category":"PHP HTTP library","requires_auth":"none","summary":"Attackers can spoof URL rewrite headers to access arbitrary internal content in PHP applications using affected Zend libraries.","user_interaction":"not_required","vuln_class":"ssrf"},"analysis_generated_by":"qwen3.8-flash-next","assigner":null,"cpe":[],"cvss":{"score":null,"severity":null,"source":null,"vector":null,"version":null},"cwes":[],"description":"zend-diactoros (and, by extension, Expressive), zend-http (and, by extension, Zend Framework MVC projects), and zend-feed (specifically, its PubSubHubbub sub-component) each contain a potential URL rewrite exploit. In each case, marshaling a request URI includes logic that introspects HTTP request headers that are specific to a given server-side URL rewrite mechanism.\n\nWhen these headers are present on systems not running the specific URL rewriting mechanism, the logic would still trigger, allowing a malicious client or proxy to emulate the headers to request arbitrary content.","ecosystems":["Packagist"],"exploits":{"exploitdb":null,"first_seen":null,"github_poc":null,"max_poc_stars":null,"metasploit":null,"nuclei":null,"refs":[],"tier":null},"has_fix":true,"headline":"Zend-HTTP URL Rewrite vulnerability","id":"GHSA-cg8w-5jrc-675g","indexable":true,"kev":null,"kind":"advisory","links":{"ecosystem":"Packagist","product":null,"products":[],"type":"ssrf","year":"2024"},"n_packages":2,"n_references":null,"packages":[{"ecosystem":"Packagist","fixed":["2.8.1"],"introduced":["1.0.0"],"last_affected":[],"package":"zendframework/zend-http","purl":null,"source":"GHSA-cg8w-5jrc-675g"},{"ecosystem":"Packagist","fixed":["2.8.1"],"introduced":["1.0.0"],"last_affected":[],"package":"zendframework/zend-http","purl":"pkg:composer/zendframework/zend-http","source":"GHSA-cg8w-5jrc-675g"}],"products":null,"published":"2024-06-07","related":[],"sources":[{"class":"attribution","licence":"CC BY 4.0","name":"GitHub Advisory Database","prefix":"GHSA"}],"ssvc":{"automatable":null,"exploitation":null,"technical_impact":null},"state":null,"updated":null,"vendors":null},"summary":"Attackers can spoof URL rewrite headers to access arbitrary internal content in PHP applications using affected Zend libraries.","url":"https://insights.sbomify.com/GHSA-cg8w-5jrc-675g/"}