{"answers":{"affected":"2 open source packages ship an affected version, including openclaw.","exploited":"There is no known exploitation of GHSA-cjv3-m589-v3rx in the wild and no public exploit code.","fix":"Upgrade openclaw to 2026.2.21 or later.","what":"GHSA-cjv3-m589-v3rx is a missing authorization vulnerability in openclaw, published on 3 Mar 2026. It can only be exploited from the same machine or local network, with no action from the victim."},"fix_prompt":"Check this codebase for GHSA-cjv3-m589-v3rx and fix it if it is affected.\n\nWhat it is: GHSA-cjv3-m589-v3rx is a missing authorization vulnerability in openclaw, published on 3 Mar 2026. It can only be exploited from the same machine or local network, with no action from the victim.\nExploitation: There is no known exploitation of GHSA-cjv3-m589-v3rx in the wild and no public exploit code.\n\nAffected packages and fixed versions:\n- openclaw (npm): affected all versions; fixed in 2026.2.21\n- openclaw (npm): affected all versions; fixed in 2026.2.21\n\nTask:\n1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.\n2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.\n3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.\n4. Run the tests and summarise what changed and why.\n5. If nothing in the project is affected, say so and change nothing.\n\nReference: https://insights.sbomify.com/GHSA-cjv3-m589-v3rx/ (Markdown: https://insights.sbomify.com/GHSA-cjv3-m589-v3rx/index.md)","id":"GHSA-cjv3-m589-v3rx","markdown":"https://insights.sbomify.com/GHSA-cjv3-m589-v3rx/index.md","name":"GHSA-cjv3-m589-v3rx","record":{"aliases":[],"analysis":{"component_type":"library","fix_type":"upgrade","impacts":["security_bypass"],"network_reachable":"adjacent_or_local","non_default_config":true,"product_category":"OpenClaw npm package","requires_auth":"none","summary":"Attackers in mixed-trust or network-visible deployments could bypass canvas route authorization due to shared-IP fallbacks, requiring an upgrade to secure access boundaries.","user_interaction":"not_required","vuln_class":"missing_authorization"},"analysis_generated_by":"qwen3.8-flash-next","assigner":null,"cpe":[],"cvss":{"score":null,"severity":null,"source":null,"vector":null,"version":null},"cwes":[],"description":"## Summary\nThis advisory tracks a defense-in-depth hardening for canvas routes. In mixed-trust or network-visible deployments, prior canvas auth/fallback behavior could broaden access beyond intended boundaries.\n\n## Deployment Context\nOpenClaw’s default model is trusted host + loopback-first access. Some operators intentionally expose canvas routes on LAN/tailnet. This update is aimed at those broader deployment patterns.\n\n## What Changed\n- Require explicit token or session-capability authorization for canvas routes.\n- Remove shared-IP fallback paths for canvas access.\n- Tighten bind/fallback behavior to fail closed.\n\n## Impact\nRisk was highest in non-loopback or mixed-trust environments. In strict single-operator trusted-host setups, practical exposure is lower.\n\n## Affected Packages / Versions\n- Package: `openclaw` (npm)\n- Vulnerable: `\u003c= 2026.2.19-2`\n- Patched: `2026.2.21` (next release target)\n\n## Fix Commit(s)\n- `c45f3c5b004c8d63dc0e282e2176f8c9355d24f1`\n- `08a7967936cfc0b2af6b27ec1f9272542648ad6c`\n\nThanks @NucleiAv for reporting.","ecosystems":["npm"],"exploits":{"exploitdb":null,"first_seen":null,"github_poc":null,"max_poc_stars":null,"metasploit":null,"nuclei":null,"refs":[],"tier":null},"has_fix":true,"headline":"OpenClaw has Canvas route hardening for mixed-trust deployments","id":"GHSA-cjv3-m589-v3rx","indexable":true,"kev":null,"kind":"advisory","links":{"ecosystem":"npm","product":null,"products":[],"type":"missing_authorization","year":"2026"},"n_packages":2,"n_references":null,"packages":[{"ecosystem":"npm","fixed":["2026.2.21"],"introduced":["0"],"last_affected":[],"package":"openclaw","purl":null,"source":"GHSA-cjv3-m589-v3rx"},{"ecosystem":"npm","fixed":["2026.2.21"],"introduced":["0"],"last_affected":[],"package":"openclaw","purl":"pkg:npm/openclaw","source":"GHSA-cjv3-m589-v3rx"}],"products":null,"published":"2026-03-03","related":[],"sources":[{"class":"attribution","licence":"CC BY 4.0","name":"GitHub Advisory Database","prefix":"GHSA"}],"ssvc":{"automatable":null,"exploitation":null,"technical_impact":null},"state":null,"updated":null,"vendors":null},"summary":"Attackers in mixed-trust or network-visible deployments could bypass canvas route authorization due to shared-IP fallbacks, requiring an upgrade to secure access boundaries.","url":"https://insights.sbomify.com/GHSA-cjv3-m589-v3rx/"}