# GHSA-cp57-fq8g-qh6v: Incorrect Check of Signer Response Norm During Verification

> The library incorrectly verifies ML-DSA signatures, allowing attackers to bypass signature validation checks and accept invalid signatures.

- **Severity:** Not scored
- **Exploited in the wild:** Not known
- **Login needed:** Not needed
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 4 Mar 2026
- **Also known as:** RUSTSEC-2026-0077

## What is GHSA-cp57-fq8g-qh6v?

GHSA-cp57-fq8g-qh6v is a vulnerability in libcrux-ml-dsa, published on 4 Mar 2026. An attacker can exploit it over the internet without logging in, with no action from the victim.

### Official description

The ML-DSA verification algorithm as specified in [FIPS 204,
subsection
6.3](https://nvlpubs.nist.gov/nistpubs/FIPS/NIST.FIPS.204.pdf#subsection.6.3)
requires verifiers to check that the infinity norm of the deserialized
signer response $z$ does not exceed $\gamma_1 - \beta$ (line 13 of
Algorithm 8).
The same check is required to be performed during signature generation.

libcrux-ml-dsa did not perform this check correctly during signature
verification, accepting signatures with signer response norm above the
allowed maximum value.  The check is correctly performed during
signing.

## Impact
Applications using libcrux-ml-dsa for signature verification would
have accepted signatures that would be rejected by a conforming
implementation.

## Mitigation
Starting from version `0.0.8`, signature verification uses the correct
value for $\gamma_1$ in the signer response norm check.

## Which versions are affected by GHSA-cp57-fq8g-qh6v?

3 open source packages ship an affected version, including libcrux-ml-dsa.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `libcrux-ml-dsa` | crates.io | All versions | 0.0.8 |
| `libcrux-ml-dsa` | crates.io | All versions | 0.0.8 |
| `libcrux-ml-dsa` | crates.io | From 0.0.0-0 | 0.0.8 |

## How do I fix GHSA-cp57-fq8g-qh6v?

Upgrade libcrux-ml-dsa to 0.0.8 or later.

## Is GHSA-cp57-fq8g-qh6v being exploited?

There is no known exploitation of GHSA-cp57-fq8g-qh6v in the wild and no public exploit code.

## Fix prompt for AI coding agents

```text
Check this codebase for GHSA-cp57-fq8g-qh6v and fix it if it is affected.

What it is: GHSA-cp57-fq8g-qh6v is a vulnerability in libcrux-ml-dsa, published on 4 Mar 2026. An attacker can exploit it over the internet without logging in, with no action from the victim.
Exploitation: There is no known exploitation of GHSA-cp57-fq8g-qh6v in the wild and no public exploit code.

Affected packages and fixed versions:
- libcrux-ml-dsa (crates.io): affected all versions; fixed in 0.0.8
- libcrux-ml-dsa (crates.io): affected all versions; fixed in 0.0.8
- libcrux-ml-dsa (crates.io): affected from 0.0.0-0; fixed in 0.0.8

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/GHSA-cp57-fq8g-qh6v/ (Markdown: https://insights.sbomify.com/GHSA-cp57-fq8g-qh6v/index.md)
```

## Sources

- OSV: https://osv.dev/vulnerability/GHSA-cp57-fq8g-qh6v

---
From sbomify Insights: https://insights.sbomify.com/GHSA-cp57-fq8g-qh6v/
Summaries are generated and may contain mistakes; the official description above is the record.
