# GHSA-cq6h-w3mc-57f4: Information exposure via query strings in URL

> Attackers can expose sensitive information via query strings in URLs, requiring user interaction to trigger the leak.

- **Severity:** Not scored
- **Exploited in the wild:** Not known
- **Login needed:** Not needed
- **Attackable:** Over the internet
- **Victim action needed:** A user has to click or open something
- **Fix available:** Yes
- **Published:** 21 Dec 2020

## What is GHSA-cq6h-w3mc-57f4?

GHSA-cq6h-w3mc-57f4 is a vulnerability in shopware/core, published on 21 Dec 2020. An attacker can exploit it over the internet without logging in, and only if a user opens a file or follows a link.

### Official description

### Impact

Information exposure via query strings in URL

### Patches
We recommend to update to the current version 6.3.4.1. You can get the update to 6.3.4.1 regularly via the Auto-Updater or directly via the download overview.

https://www.shopware.com/en/download/#shopware-6

### Workarounds
For older versions of 6.1 and 6.2 the corresponding changes are also available via plugin:

https://store.shopware.com/en/detail/index/sArticle/518463/number/Swag136939272659

### For more information
https://docs.shopware.com/en/shopware-6-en/security-updates/security-update-12-2020

### Credits
We would like to thank <a rel="noopener" href="https://www.vater-it.de/">Oliver Herrmann</a> for reporting this issue.

## Which versions are affected by GHSA-cq6h-w3mc-57f4?

4 open source packages ship an affected version, including shopware/core and shopware/platform.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `shopware/core` | Packagist | All versions | 6.3.4.1 |
| `shopware/core` | Packagist | All versions | 6.3.4.1 |
| `shopware/platform` | Packagist | All versions | 6.3.4.1 |
| `shopware/platform` | Packagist | All versions | 6.3.4.1 |

## How do I fix GHSA-cq6h-w3mc-57f4?

Upgrade shopware/core to 6.3.4.1 or later.

## Is GHSA-cq6h-w3mc-57f4 being exploited?

There is no known exploitation of GHSA-cq6h-w3mc-57f4 in the wild and no public exploit code.

## Fix prompt for AI coding agents

```text
Check this codebase for GHSA-cq6h-w3mc-57f4 and fix it if it is affected.

What it is: GHSA-cq6h-w3mc-57f4 is a vulnerability in shopware/core, published on 21 Dec 2020. An attacker can exploit it over the internet without logging in, and only if a user opens a file or follows a link.
Exploitation: There is no known exploitation of GHSA-cq6h-w3mc-57f4 in the wild and no public exploit code.

Affected packages and fixed versions:
- shopware/core (Packagist): affected all versions; fixed in 6.3.4.1
- shopware/core (Packagist): affected all versions; fixed in 6.3.4.1
- shopware/platform (Packagist): affected all versions; fixed in 6.3.4.1
- shopware/platform (Packagist): affected all versions; fixed in 6.3.4.1

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/GHSA-cq6h-w3mc-57f4/ (Markdown: https://insights.sbomify.com/GHSA-cq6h-w3mc-57f4/index.md)
```

## Sources

- OSV: https://osv.dev/vulnerability/GHSA-cq6h-w3mc-57f4

---
From sbomify Insights: https://insights.sbomify.com/GHSA-cq6h-w3mc-57f4/
Summaries are generated and may contain mistakes; the official description above is the record.
