{"answers":{"affected":"2 open source packages ship an affected version, including ids-enterprise.","exploited":"There is no known exploitation of GHSA-crfx-5phg-hmw9 in the wild and no public exploit code.","fix":"Upgrade ids-enterprise to 4.18.2 or later.","what":"GHSA-crfx-5phg-hmw9 is a cross-site scripting vulnerability in ids-enterprise, published on 13 Jun 2019. An attacker can exploit it over the internet without logging in, and only if a user opens a file or follows a link."},"fix_prompt":"Check this codebase for GHSA-crfx-5phg-hmw9 and fix it if it is affected.\n\nWhat it is: GHSA-crfx-5phg-hmw9 is a cross-site scripting vulnerability in ids-enterprise, published on 13 Jun 2019. An attacker can exploit it over the internet without logging in, and only if a user opens a file or follows a link.\nExploitation: There is no known exploitation of GHSA-crfx-5phg-hmw9 in the wild and no public exploit code.\n\nAffected packages and fixed versions:\n- ids-enterprise (npm): affected all versions; fixed in 4.18.2\n- ids-enterprise (npm): affected all versions; fixed in 4.18.2\n\nTask:\n1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.\n2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.\n3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.\n4. Run the tests and summarise what changed and why.\n5. If nothing in the project is affected, say so and change nothing.\n\nReference: https://insights.sbomify.com/GHSA-crfx-5phg-hmw9/ (Markdown: https://insights.sbomify.com/GHSA-crfx-5phg-hmw9/index.md)","id":"GHSA-crfx-5phg-hmw9","markdown":"https://insights.sbomify.com/GHSA-crfx-5phg-hmw9/index.md","name":"GHSA-crfx-5phg-hmw9","record":{"aliases":[],"analysis":{"component_type":"library","fix_type":"upgrade","impacts":["code_execution"],"network_reachable":"yes","non_default_config":false,"product_category":"JavaScript UI library","requires_auth":"none","summary":"Attackers can execute arbitrary JavaScript via unencoded script tags in the soho-autocomplete component, requiring user interaction.","user_interaction":"required","vuln_class":"xss"},"analysis_generated_by":"qwen3.8-flash-next","assigner":null,"cpe":[],"cvss":{"score":null,"severity":null,"source":null,"vector":null,"version":null},"cwes":[],"description":"Versions of `ids-enterprise` prior to 4.18.2 are vulnerable to Cross-Site Scripting (XSS). Script tags in the `soho-autocomplete` component are not properly encoded and may allow attackers to execute arbitrary JavaScript.\n\n## Recommendation\n\nUpgrade to version 4.18.2 or later","ecosystems":["npm"],"exploits":{"exploitdb":null,"first_seen":null,"github_poc":null,"max_poc_stars":null,"metasploit":null,"nuclei":null,"refs":[],"tier":null},"has_fix":true,"headline":"Cross-Site Scripting in ids-enterprise","id":"GHSA-crfx-5phg-hmw9","indexable":true,"kev":null,"kind":"advisory","links":{"ecosystem":"npm","product":null,"products":[],"type":"xss","year":"2019"},"n_packages":2,"n_references":null,"packages":[{"ecosystem":"npm","fixed":["4.18.2"],"introduced":["0"],"last_affected":[],"package":"ids-enterprise","purl":null,"source":"GHSA-crfx-5phg-hmw9"},{"ecosystem":"npm","fixed":["4.18.2"],"introduced":["0"],"last_affected":[],"package":"ids-enterprise","purl":"pkg:npm/ids-enterprise","source":"GHSA-crfx-5phg-hmw9"}],"products":null,"published":"2019-06-13","related":[],"sources":[{"class":"attribution","licence":"CC BY 4.0","name":"GitHub Advisory Database","prefix":"GHSA"}],"ssvc":{"automatable":null,"exploitation":null,"technical_impact":null},"state":null,"updated":null,"vendors":null},"summary":"Attackers can execute arbitrary JavaScript via unencoded script tags in the soho-autocomplete component, requiring user interaction.","url":"https://insights.sbomify.com/GHSA-crfx-5phg-hmw9/"}