{"answers":{"affected":"4 open source packages ship an affected version, including com.vaadin:vaadin-text-field-flow.","exploited":"There is no known exploitation of GHSA-crh4-294p-vcfq in the wild and no public exploit code.","fix":"Upgrade com.vaadin:vaadin-text-field-flow to a fixed version for your release line: 2.3.3 or 4.0.3.","what":"GHSA-crh4-294p-vcfq is a denial of service vulnerability in com.vaadin:vaadin-text-field-flow, published on 19 Apr 2021. An attacker can exploit it over the internet without logging in, with no action from the victim."},"fix_prompt":"Check this codebase for GHSA-crh4-294p-vcfq and fix it if it is affected.\n\nWhat it is: GHSA-crh4-294p-vcfq is a denial of service vulnerability in com.vaadin:vaadin-text-field-flow, published on 19 Apr 2021. An attacker can exploit it over the internet without logging in, with no action from the victim.\nExploitation: There is no known exploitation of GHSA-crh4-294p-vcfq in the wild and no public exploit code.\n\nAffected packages and fixed versions:\n- com.vaadin:vaadin-text-field-flow (Maven): affected from 2.0.4; fixed in 2.3.3\n- com.vaadin:vaadin-text-field-flow (Maven): affected from 2.0.4; fixed in 2.3.3\n- com.vaadin:vaadin-text-field-flow (Maven): affected from 3.0.0; fixed in 4.0.3\n- com.vaadin:vaadin-text-field-flow (Maven): affected from 3.0.0; fixed in 4.0.3\n\nTask:\n1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.\n2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.\n3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.\n4. Run the tests and summarise what changed and why.\n5. If nothing in the project is affected, say so and change nothing.\n\nReference: https://insights.sbomify.com/GHSA-crh4-294p-vcfq/ (Markdown: https://insights.sbomify.com/GHSA-crh4-294p-vcfq/index.md)","id":"GHSA-crh4-294p-vcfq","markdown":"https://insights.sbomify.com/GHSA-crh4-294p-vcfq/index.md","name":"GHSA-crh4-294p-vcfq","record":{"aliases":[],"analysis":{"component_type":"library","fix_type":"upgrade","impacts":["denial_of_service"],"network_reachable":"yes","non_default_config":false,"product_category":"Vaadin UI library","requires_auth":"none","summary":"Attackers can cause denial of service in Vaadin applications by submitting malicious email addresses to the EmailField component.","user_interaction":"not_required","vuln_class":"denial_of_service"},"analysis_generated_by":"qwen3.8-flash-next","assigner":null,"cpe":[],"cvss":{"score":null,"severity":null,"source":null,"vector":null,"version":null},"cwes":[],"description":"Unsafe validation RegEx in `EmailField` component in `com.vaadin:vaadin-text-field-flow` versions 2.0.4 through 2.3.2 (Vaadin 14.0.6 through 14.4.3), and 3.0.0 through 4.0.2 (Vaadin 15.0.0 through 17.0.10) allows attackers to cause uncontrolled resource consumption by submitting malicious email addresses.\n\n- https://vaadin.com/security/cve-2021-31405","ecosystems":["Maven"],"exploits":{"exploitdb":null,"first_seen":null,"github_poc":null,"max_poc_stars":null,"metasploit":null,"nuclei":null,"refs":[],"tier":null},"has_fix":true,"headline":"Regular expression denial of service (ReDoS) in EmailField component in Vaadin 14 and 15-17","id":"GHSA-crh4-294p-vcfq","indexable":true,"kev":null,"kind":"advisory","links":{"ecosystem":"Maven","product":null,"products":[],"type":"denial_of_service","year":"2021"},"n_packages":4,"n_references":null,"packages":[{"ecosystem":"Maven","fixed":["2.3.3"],"introduced":["2.0.4"],"last_affected":[],"package":"com.vaadin:vaadin-text-field-flow","purl":null,"source":"GHSA-crh4-294p-vcfq"},{"ecosystem":"Maven","fixed":["2.3.3"],"introduced":["2.0.4"],"last_affected":[],"package":"com.vaadin:vaadin-text-field-flow","purl":"pkg:maven/com.vaadin/vaadin-text-field-flow","source":"GHSA-crh4-294p-vcfq"},{"ecosystem":"Maven","fixed":["4.0.3"],"introduced":["3.0.0"],"last_affected":[],"package":"com.vaadin:vaadin-text-field-flow","purl":null,"source":"GHSA-crh4-294p-vcfq"},{"ecosystem":"Maven","fixed":["4.0.3"],"introduced":["3.0.0"],"last_affected":[],"package":"com.vaadin:vaadin-text-field-flow","purl":"pkg:maven/com.vaadin/vaadin-text-field-flow","source":"GHSA-crh4-294p-vcfq"}],"products":null,"published":"2021-04-19","related":[],"sources":[{"class":"attribution","licence":"CC BY 4.0","name":"GitHub Advisory Database","prefix":"GHSA"}],"ssvc":{"automatable":null,"exploitation":null,"technical_impact":null},"state":null,"updated":null,"vendors":null},"summary":"Attackers can cause denial of service in Vaadin applications by submitting malicious email addresses to the EmailField component.","url":"https://insights.sbomify.com/GHSA-crh4-294p-vcfq/"}