# GHSA-cvp8-5r8g-fhvq: omniauth-saml vulnerable to Improper Verification of Cryptographic Signature

> Attackers can bypass SAML signature verification to impersonate users and gain unauthorized access to applications using this Ruby authentication library.

- **Severity:** Not scored
- **Exploited in the wild:** Not known
- **Login needed:** Not needed
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 11 Sep 2024

## What is GHSA-cvp8-5r8g-fhvq?

GHSA-cvp8-5r8g-fhvq is a vulnerability in omniauth-saml, published on 11 Sep 2024. An attacker can exploit it over the internet without logging in, with no action from the victim.

### Official description

ruby-saml, the dependent SAML gem of omniauth-saml has a signature wrapping vulnerability in <= v1.12.0 and v1.13.0 to v1.16.0 , see https://github.com/SAML-Toolkits/ruby-saml/security/advisories/GHSA-jw9c-mfg7-9rx2 
As a result, omniauth-saml created a [new release](https://github.com/omniauth/omniauth-saml/releases) by upgrading ruby-saml to the patched versions v1.17.

## Which versions are affected by GHSA-cvp8-5r8g-fhvq?

6 open source packages ship an affected version, including omniauth-saml.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `omniauth-saml` | RubyGems | All versions | 1.10.5 |
| `omniauth-saml` | RubyGems | All versions | 1.10.5 |
| `omniauth-saml` | RubyGems | From 2.0.0 | 2.1.2 |
| `omniauth-saml` | RubyGems | From 2.0.0 | 2.1.2 |
| `omniauth-saml` | RubyGems | From 2.2.0 | 2.2.1 |
| `omniauth-saml` | RubyGems | From 2.2.0 | 2.2.1 |

## How do I fix GHSA-cvp8-5r8g-fhvq?

Upgrade omniauth-saml to a fixed version for your release line: 1.10.5, 2.1.2 or 2.2.1.

## Is GHSA-cvp8-5r8g-fhvq being exploited?

There is no known exploitation of GHSA-cvp8-5r8g-fhvq in the wild and no public exploit code.

## Fix prompt for AI coding agents

```text
Check this codebase for GHSA-cvp8-5r8g-fhvq and fix it if it is affected.

What it is: GHSA-cvp8-5r8g-fhvq is a vulnerability in omniauth-saml, published on 11 Sep 2024. An attacker can exploit it over the internet without logging in, with no action from the victim.
Exploitation: There is no known exploitation of GHSA-cvp8-5r8g-fhvq in the wild and no public exploit code.

Affected packages and fixed versions:
- omniauth-saml (RubyGems): affected all versions; fixed in 1.10.5
- omniauth-saml (RubyGems): affected all versions; fixed in 1.10.5
- omniauth-saml (RubyGems): affected from 2.0.0; fixed in 2.1.2
- omniauth-saml (RubyGems): affected from 2.0.0; fixed in 2.1.2
- omniauth-saml (RubyGems): affected from 2.2.0; fixed in 2.2.1
- omniauth-saml (RubyGems): affected from 2.2.0; fixed in 2.2.1

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/GHSA-cvp8-5r8g-fhvq/ (Markdown: https://insights.sbomify.com/GHSA-cvp8-5r8g-fhvq/index.md)
```

## Sources

- OSV: https://osv.dev/vulnerability/GHSA-cvp8-5r8g-fhvq

---
From sbomify Insights: https://insights.sbomify.com/GHSA-cvp8-5r8g-fhvq/
Summaries are generated and may contain mistakes; the official description above is the record.
