{"answers":{"affected":"2 open source packages ship an affected version, including verbb/formie.","exploited":"There is no known exploitation of GHSA-cvpc-hccg-wmw4 in the wild and no public exploit code.","fix":"Upgrade verbb/formie to 3.1.28 or later.","what":"GHSA-cvpc-hccg-wmw4 is a missing authorization vulnerability in verbb/formie, published on 17 Jul 2026. Any signed-in user can exploit it over the network, with no action from the victim."},"fix_prompt":"Check this codebase for GHSA-cvpc-hccg-wmw4 and fix it if it is affected.\n\nWhat it is: GHSA-cvpc-hccg-wmw4 is a missing authorization vulnerability in verbb/formie, published on 17 Jul 2026. Any signed-in user can exploit it over the network, with no action from the victim.\nExploitation: There is no known exploitation of GHSA-cvpc-hccg-wmw4 in the wild and no public exploit code.\n\nAffected packages and fixed versions:\n- verbb/formie (Packagist): affected all versions; fixed in 3.1.28\n- verbb/formie (Packagist): affected all versions; fixed in 3.1.28\n\nTask:\n1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.\n2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.\n3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.\n4. Run the tests and summarise what changed and why.\n5. If nothing in the project is affected, say so and change nothing.\n\nReference: https://insights.sbomify.com/GHSA-cvpc-hccg-wmw4/ (Markdown: https://insights.sbomify.com/GHSA-cvpc-hccg-wmw4/index.md)","id":"GHSA-cvpc-hccg-wmw4","markdown":"https://insights.sbomify.com/GHSA-cvpc-hccg-wmw4/index.md","name":"GHSA-cvpc-hccg-wmw4","record":{"aliases":[],"analysis":{"component_type":"cms_plugin","fix_type":"patch","impacts":["data_modify","security_bypass"],"network_reachable":"yes","non_default_config":false,"product_category":"Craft CMS plugin","requires_auth":"low_privilege","summary":"Low-privileged Craft CMS users can modify global Formie plugin settings due to missing server-side authorization checks.","user_interaction":"not_required","vuln_class":"missing_authorization"},"analysis_generated_by":"qwen3.8-flash-next","assigner":null,"cpe":[],"cvss":{"score":null,"severity":null,"source":null,"vector":null,"version":null},"cwes":[],"description":"Formie contains a missing authorization vulnerability in administrative settings routes. An authenticated, non-admin Craft CMS control panel user with limited Formie access could directly access Formie settings pages and modify global plugin configuration.\n\nIn affected versions, Formie settings-related control panel routes did not consistently enforce the required settings permission on the server side. A low-privileged Craft CMS control panel user with limited Formie access could access /admin/formie/settings, save changes to global plugin settings, and access /admin/formie/settings/import-export.\n\nThe issue has been fixed by enforcing the formie-accessSettings permission across Formie settings controllers and related settings actions.\n\n### Impact\nAn authenticated low-privileged CP user may be able to:\n- Access Formie administrative settings.\n- Modify global Formie plugin configuration.\n- Access Formie import/export settings functionality.\n\nThis may allow configuration tampering and disruption of form-related workflows. Exploitation requires an authenticated Craft CMS control panel account.","ecosystems":["Packagist"],"exploits":{"exploitdb":null,"first_seen":null,"github_poc":null,"max_poc_stars":null,"metasploit":null,"nuclei":null,"refs":[],"tier":null},"has_fix":true,"headline":"Formie: Missing authorization in administrative settings allows low-privileged CP users to modify plugin configuration","id":"GHSA-cvpc-hccg-wmw4","indexable":true,"kev":null,"kind":"advisory","links":{"ecosystem":"Packagist","product":null,"products":[],"type":"missing_authorization","year":"2026"},"n_packages":2,"n_references":null,"packages":[{"ecosystem":"Packagist","fixed":["3.1.28"],"introduced":["0"],"last_affected":[],"package":"verbb/formie","purl":null,"source":"GHSA-cvpc-hccg-wmw4"},{"ecosystem":"Packagist","fixed":["3.1.28"],"introduced":["0"],"last_affected":[],"package":"verbb/formie","purl":"pkg:composer/verbb/formie","source":"GHSA-cvpc-hccg-wmw4"}],"products":null,"published":"2026-07-17","related":[],"sources":[{"class":"attribution","licence":"CC BY 4.0","name":"GitHub Advisory Database","prefix":"GHSA"}],"ssvc":{"automatable":null,"exploitation":null,"technical_impact":null},"state":null,"updated":null,"vendors":null},"summary":"Low-privileged Craft CMS users can modify global Formie plugin settings due to missing server-side authorization checks.","url":"https://insights.sbomify.com/GHSA-cvpc-hccg-wmw4/"}