GHSA-f3r2-88mq-9v4g Auth0 Symfony SDK has Improper Audience Validation via Auth0-PHP SDK
Improper audience validation allows accepting ID tokens as Access tokens, bypassing authentication checks in applications using the Auth0 Symfony SDK.
- Exploited in the wild
- Not known
- Login needed
- Not needed
- Attackable
- Over the internet
- Victim action needed
- Not needed
- Fix
- Available
What is GHSA-f3r2-88mq-9v4g?
GHSA-f3r2-88mq-9v4g is an authentication bypass vulnerability in auth0/symfony, published on 17 Dec 2025. An attacker can exploit it over the internet without logging in, with no action from the victim.
Official description
Description
In applications built with the Auth0-PHP SDK, the audience validation in access tokens is performed improperly. Without proper validation, affected applications may accept ID tokens as Access tokens.
Affected product and versions
Projects are affected if they meet the following preconditions:
- Applications using the Auth0 Symfony SDK with versions between 5.0.0 and 5.5.0
- Auth0 Symfony SDK uses the Auth0-PHP SDK with versions between 8.0.0 and 8.17.0.
Resolution
Upgrade Auth0/symfony to version 5.6.0 or greater.
Acknowledgement
Okta would like to thank Jafar Sadiq (iaf4r) for their discovery and responsible disclosure.
Which versions are affected by GHSA-f3r2-88mq-9v4g?
2 open source packages ship an affected version, including auth0/symfony.
| Package | Affected | Fixed in |
|---|---|---|
auth0/symfony Packagist | From 5.0.0 | 5.6.0 |
auth0/symfony Packagist | From 5.0.0 | 5.6.0 |
How do I fix GHSA-f3r2-88mq-9v4g?
Upgrade auth0/symfony to 5.6.0 or later.
Upgrade, and rotate credentials and sessions that may have been exposed. More about Authentication bypass.
Is GHSA-f3r2-88mq-9v4g being exploited?
There is no known exploitation of GHSA-f3r2-88mq-9v4g in the wild and no public exploit code.