# GHSA-f3r2-88mq-9v4g: Auth0 Symfony SDK has Improper Audience Validation via Auth0-PHP SDK

> Improper audience validation allows accepting ID tokens as Access tokens, bypassing authentication checks in applications using the Auth0 Symfony SDK.

- **Severity:** Not scored
- **Exploited in the wild:** Not known
- **Login needed:** Not needed
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 17 Dec 2025

## What is GHSA-f3r2-88mq-9v4g?

GHSA-f3r2-88mq-9v4g is an authentication bypass vulnerability in auth0/symfony, published on 17 Dec 2025. An attacker can exploit it over the internet without logging in, with no action from the victim.

### Official description

### Description
In applications built with the Auth0-PHP SDK, the audience validation in access tokens is performed improperly. Without proper validation, affected applications may accept ID tokens as Access tokens.

### Affected product and versions
Projects are affected if they meet the following preconditions:

- Applications using the Auth0 Symfony SDK with versions between 5.0.0 and 5.5.0
- Auth0 Symfony SDK uses the Auth0-PHP SDK with versions between 8.0.0 and 8.17.0.

### Resolution
Upgrade Auth0/symfony to version 5.6.0 or greater.

### Acknowledgement
Okta would like to thank Jafar Sadiq (iaf4r) for their discovery and responsible disclosure.

## Which versions are affected by GHSA-f3r2-88mq-9v4g?

2 open source packages ship an affected version, including auth0/symfony.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `auth0/symfony` | Packagist | From 5.0.0 | 5.6.0 |
| `auth0/symfony` | Packagist | From 5.0.0 | 5.6.0 |

## How do I fix GHSA-f3r2-88mq-9v4g?

Upgrade auth0/symfony to 5.6.0 or later.

## Is GHSA-f3r2-88mq-9v4g being exploited?

There is no known exploitation of GHSA-f3r2-88mq-9v4g in the wild and no public exploit code.

## Fix prompt for AI coding agents

```text
Check this codebase for GHSA-f3r2-88mq-9v4g and fix it if it is affected.

What it is: GHSA-f3r2-88mq-9v4g is an authentication bypass vulnerability in auth0/symfony, published on 17 Dec 2025. An attacker can exploit it over the internet without logging in, with no action from the victim.
Exploitation: There is no known exploitation of GHSA-f3r2-88mq-9v4g in the wild and no public exploit code.

Affected packages and fixed versions:
- auth0/symfony (Packagist): affected from 5.0.0; fixed in 5.6.0
- auth0/symfony (Packagist): affected from 5.0.0; fixed in 5.6.0

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/GHSA-f3r2-88mq-9v4g/ (Markdown: https://insights.sbomify.com/GHSA-f3r2-88mq-9v4g/index.md)
```

## Sources

- OSV: https://osv.dev/vulnerability/GHSA-f3r2-88mq-9v4g

---
From sbomify Insights: https://insights.sbomify.com/GHSA-f3r2-88mq-9v4g/
Summaries are generated and may contain mistakes; the official description above is the record.
