{"answers":{"affected":"2 open source packages ship an affected version, including sapper.","exploited":"There is no known exploitation of GHSA-f3vw-587g-r29g in the wild and no public exploit code.","fix":"Upgrade sapper to 0.27.11 or later.","what":"GHSA-f3vw-587g-r29g is a path traversal vulnerability in sapper, published on 3 Sep 2020. An attacker can exploit it over the internet without logging in, with no action from the victim."},"fix_prompt":"Check this codebase for GHSA-f3vw-587g-r29g and fix it if it is affected.\n\nWhat it is: GHSA-f3vw-587g-r29g is a path traversal vulnerability in sapper, published on 3 Sep 2020. An attacker can exploit it over the internet without logging in, with no action from the victim.\nExploitation: There is no known exploitation of GHSA-f3vw-587g-r29g in the wild and no public exploit code.\n\nAffected packages and fixed versions:\n- sapper (npm): affected all versions; fixed in 0.27.11\n- sapper (npm): affected all versions; fixed in 0.27.11\n\nTask:\n1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.\n2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.\n3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.\n4. Run the tests and summarise what changed and why.\n5. If nothing in the project is affected, say so and change nothing.\n\nReference: https://insights.sbomify.com/GHSA-f3vw-587g-r29g/ (Markdown: https://insights.sbomify.com/GHSA-f3vw-587g-r29g/index.md)","id":"GHSA-f3vw-587g-r29g","markdown":"https://insights.sbomify.com/GHSA-f3vw-587g-r29g/index.md","name":"GHSA-f3vw-587g-r29g","record":{"aliases":[],"analysis":{"component_type":"web_application","fix_type":"upgrade","impacts":["data_read"],"network_reachable":"yes","non_default_config":false,"product_category":"Sapper web framework","requires_auth":"none","summary":"Attackers can read sensitive server files via URL-encoded path traversal in Sapper applications, requiring an upgrade to mitigate.","user_interaction":"not_required","vuln_class":"path_traversal"},"analysis_generated_by":"qwen3.8-flash-next","assigner":null,"cpe":[],"cvss":{"score":null,"severity":null,"source":null,"vector":null,"version":null},"cwes":[],"description":"Versions of `sapper` prior to 0.27.11 are vulnerable to Path Traversal. It is possible to access sensitive files on the server through HTTP requests containing URL-encoded `../`.  \n\nYou may test a `sapper` application running in prod mode with `curl -vvv http://localhost:3000/client/750af05c3a69ddc6073a/%252e%252e/%252e%252e/%252e%252e/%252e%252e/%252e%252e/%252e%252e/%252e%252e/%252e%252e/etc/passwd`.\n\n## Recommendation\n\nUpgrade to version 0.27.11 or later.","ecosystems":["npm"],"exploits":{"exploitdb":null,"first_seen":null,"github_poc":null,"max_poc_stars":null,"metasploit":null,"nuclei":null,"refs":[],"tier":null},"has_fix":true,"headline":"Path Traversal in sapper","id":"GHSA-f3vw-587g-r29g","indexable":true,"kev":null,"kind":"advisory","links":{"ecosystem":"npm","product":null,"products":[],"type":"path_traversal","year":"2020"},"n_packages":2,"n_references":null,"packages":[{"ecosystem":"npm","fixed":["0.27.11"],"introduced":["0"],"last_affected":[],"package":"sapper","purl":null,"source":"GHSA-f3vw-587g-r29g"},{"ecosystem":"npm","fixed":["0.27.11"],"introduced":["0"],"last_affected":[],"package":"sapper","purl":"pkg:npm/sapper","source":"GHSA-f3vw-587g-r29g"}],"products":null,"published":"2020-09-03","related":[],"sources":[{"class":"attribution","licence":"CC BY 4.0","name":"GitHub Advisory Database","prefix":"GHSA"}],"ssvc":{"automatable":null,"exploitation":null,"technical_impact":null},"state":null,"updated":null,"vendors":null},"summary":"Attackers can read sensitive server files via URL-encoded path traversal in Sapper applications, requiring an upgrade to mitigate.","url":"https://insights.sbomify.com/GHSA-f3vw-587g-r29g/"}