{"answers":{"affected":"2 open source packages ship an affected version, including express-cart.","exploited":"There is no known exploitation of GHSA-f5cv-xrv9-r8w7 in the wild and no public exploit code.","fix":"Upgrade express-cart to 1.1.8 or later.","what":"GHSA-f5cv-xrv9-r8w7 is a SQL injection vulnerability in express-cart, published on 1 Sep 2020. An attacker can exploit it over the internet without logging in, with no action from the victim."},"fix_prompt":"Check this codebase for GHSA-f5cv-xrv9-r8w7 and fix it if it is affected.\n\nWhat it is: GHSA-f5cv-xrv9-r8w7 is a SQL injection vulnerability in express-cart, published on 1 Sep 2020. An attacker can exploit it over the internet without logging in, with no action from the victim.\nExploitation: There is no known exploitation of GHSA-f5cv-xrv9-r8w7 in the wild and no public exploit code.\n\nAffected packages and fixed versions:\n- express-cart (npm): affected all versions; fixed in 1.1.8\n- express-cart (npm): affected all versions; fixed in 1.1.8\n\nTask:\n1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.\n2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.\n3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.\n4. Run the tests and summarise what changed and why.\n5. If nothing in the project is affected, say so and change nothing.\n\nReference: https://insights.sbomify.com/GHSA-f5cv-xrv9-r8w7/ (Markdown: https://insights.sbomify.com/GHSA-f5cv-xrv9-r8w7/index.md)","id":"GHSA-f5cv-xrv9-r8w7","markdown":"https://insights.sbomify.com/GHSA-f5cv-xrv9-r8w7/index.md","name":"GHSA-f5cv-xrv9-r8w7","record":{"aliases":[],"analysis":{"component_type":"library","fix_type":"upgrade","impacts":["data_read","account_takeover"],"network_reachable":"yes","non_default_config":false,"product_category":"Node.js shopping cart","requires_auth":"none","summary":"Attackers can exploit NoSQL injection in login handlers to extract authentication tokens and gain unauthorized access to user or admin accounts.","user_interaction":"not_required","vuln_class":"sql_injection"},"analysis_generated_by":"qwen3.8-flash-next","assigner":null,"cpe":[],"cvss":{"score":null,"severity":null,"source":null,"vector":null,"version":null},"cwes":[],"description":"Versions of `express-cart` before 1.1.8 are vulnerable to NoSQL injection. \n\nThe vulnerability is caused by the lack of user input sanitization in the login handlers. In both cases, the customer login and the admin login, parameters from the JSON body are sent directly into the MongoDB query which allows to insert operators. \n\nThese operators can be used to extract the value of the field blindly in the same manner of a blind SQL injection. In this case, the `$regex` operator is used to guess each character of the token from the start.\n\n## Recommendation\n\nUpdate to version 1.1.8 or later.","ecosystems":["npm"],"exploits":{"exploitdb":null,"first_seen":null,"github_poc":null,"max_poc_stars":null,"metasploit":null,"nuclei":null,"refs":[],"tier":null},"has_fix":true,"headline":"NoSQL injection in express-cart","id":"GHSA-f5cv-xrv9-r8w7","indexable":true,"kev":null,"kind":"advisory","links":{"ecosystem":"npm","product":null,"products":[],"type":"sql_injection","year":"2020"},"n_packages":2,"n_references":null,"packages":[{"ecosystem":"npm","fixed":["1.1.8"],"introduced":["0"],"last_affected":[],"package":"express-cart","purl":null,"source":"GHSA-f5cv-xrv9-r8w7"},{"ecosystem":"npm","fixed":["1.1.8"],"introduced":["0"],"last_affected":[],"package":"express-cart","purl":"pkg:npm/express-cart","source":"GHSA-f5cv-xrv9-r8w7"}],"products":null,"published":"2020-09-01","related":[],"sources":[{"class":"attribution","licence":"CC BY 4.0","name":"GitHub Advisory Database","prefix":"GHSA"}],"ssvc":{"automatable":null,"exploitation":null,"technical_impact":null},"state":null,"updated":null,"vendors":null},"summary":"Attackers can exploit NoSQL injection in login handlers to extract authentication tokens and gain unauthorized access to user or admin accounts.","url":"https://insights.sbomify.com/GHSA-f5cv-xrv9-r8w7/"}